6.3.0 community failed to start component

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
snowman
Junior Boarder
Junior Boarder
Posts: 33
Joined: Mon Feb 21, 2011 8:32 pm

6.3.0 community failed to start component

Post by snowman » Sat Feb 28, 2015 10:14 pm

Hello,

I tried to update from 6.2.5 to 6.3.0 but it wont work. I tried the migration guide as well as fresh install using openkm+tomcat bundle. I always get the same error in catalina.log:
org.apache.catalina.LifecycleException: Failed to start component
and later:
Caused by: java.lang.NoClassDefFoundError: com/openkm/core/PathNotFoundException
[...]
Caused by: java.lang.ClassNotFoundException: com.openkm.core.PathNotFoundException

Unfortunately, there is no other hint on whats wrong.
Skimming through other threads I checked java version, etc. Version is the same as for 6.2.5. No reason why it should fail.

Thank you for any hint you can give.
Attachments
catalina.zip
log after start
(1.37 KiB) Downloaded 76 times

jllort
Moderator
Moderator
Posts: 10905
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: 6.3.0 community failed to start component

Post by jllort » Sun Mar 01, 2015 4:39 pm

has the user with you're starting openkm enought grants to write in the /data/bin/openkm-6.3.0/tomcat/ folder ?

snowman
Junior Boarder
Junior Boarder
Posts: 33
Joined: Mon Feb 21, 2011 8:32 pm

Re: 6.3.0 community failed to start component

Post by snowman » Mon Mar 02, 2015 12:26 am

everything (download from sourceforge,unpacking, starting) was done using root. Unfortunately I cannot find a reference on which "path not found".
Is there any other reference pointing outside the package apart from java?

jllort
Moderator
Moderator
Posts: 10905
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: 6.3.0 community failed to start component

Post by jllort » Wed Mar 04, 2015 9:11 am

Be sure application is starting with jdk 1.7 and not much else. My suggestion is start from console $TOMCAT_HOME/bin/catalina.sh run

Post Reply