• Text extraction queue broken

  • We tried to make OpenKM as intuitive as possible, but an advice is always welcome.
We tried to make OpenKM as intuitive as possible, but an advice is always welcome.
Forum rules: Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
 #53779  by scrumi
I have 70,000 documents or so stuck in the queue. Logs show a continuous stream of a version of this:
Code: Select all
2022-08-04 17:48:55,318 [pool-14908-thread-4] [] WARN  c.o.extractor.TextExtractorThread - /home/openkm/tomcat-8.5.34/repository/datastore/57/6f/91/4a/576f914a-b4a1-499a-9553-c5acf1a4064c (No such file or directory)
java.io.FileNotFoundException: /home/openkm/tomcat-8.5.34/repository/datastore/57/6f/91/4a/576f914a-b4a1-499a-9553-c5acf1a4064c (No such file or directory)
	at java.io.FileInputStream.open0(Native Method) ~[na:1.8.0_312]
	at java.io.FileInputStream.open(FileInputStream.java:195) ~[na:1.8.0_312]
	at java.io.FileInputStream.<init>(FileInputStream.java:138) ~[na:1.8.0_312]
	at com.openkm.module.db.stuff.FsDataStore.read(FsDataStore.java:65) ~[classes/:6.3.11]
	at com.openkm.dao.NodeDocumentDAO.textExtractorHelper(NodeDocumentDAO.java:1402) ~[classes/:6.3.11]
	at com.openkm.extractor.TextExtractorThread.run(TextExtractorThread.java:49) ~[classes/:6.3.11]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [na:1.8.0_312]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [na:1.8.0_312]
	at java.lang.Thread.run(Thread.java:748) [na:1.8.0_312]
 #53792  by jllort
1- check if the document exist ( should be )
2- usually the problem is because started OpenKM with root user and then the document has been created with root user as the owner. Later when executed OpenKM as service ( it uses openkm user ) do not have grants to access to this document. To solve, I suggest update the owner for all the tomcat folder

chown openkm:openkm -Rf tomcat-xxxx

About Us

OpenKM is part of the management software. A management software is a program that facilitates the accomplishment of administrative tasks. OpenKM is a document management system that allows you to manage business content and workflow in a more efficient way. Document managers guarantee data protection by establishing information security for business content.