• Will Not Start After 6.3.11 to 6.3.12 Upgrade

  • Problems with installing OpenKM? No problemo, the solution is closer than you think.
Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules: Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
 #54490  by ChrisW
 
Followed the upgrade instructions for 6.3.11 to 6.3.12. Once hibernate.hbm2ddl=update was set and restarted tomcat, it does not complete and stays in the update state. Looked at the openkm.log and see some errors.
Code: Select all
2023-11-07 20:55:00,050 [Thread-2764] [] INFO  c.o.extractor.TextExtractorWorker - processSerial.Working on {docUuid=cc76c4a2-97b8-4976-bb40-705daebe365c, docPath=/okm:root/XXXXX/Personnel/Contractors/YYYY.doc, docVerUuid=95fcc28e-ed67-4be3-a1c8-20f3a43723d5, date=Tue Apr 27 13:40:52 EDT 2021}
2023-11-07 20:55:00,092 [Thread-2764] [] WARN  o.h.util.JDBCExceptionReporter - SQL Error: 1366, SQLState: 22001
2023-11-07 20:55:00,092 [Thread-2764] [] ERROR o.h.util.JDBCExceptionReporter - Data truncation: Incorrect string value: '\xE2\x80\x8Btio...' for column `okmdb`.`OKM_NODE_DOCUMENT`.`NDC_TEXT` at row 1
2023-11-07 20:55:00,095 [Thread-2764] [] WARN  c.o.extractor.TextExtractorWorker - could not update: [com.openkm.dao.bean.NodeDocument#cc76c4a2-97b8-4976-bb40-705daebe365c]
Trying to figure out what is happening. Is it having a problem with that identified document? If that's the case, how do I get around it?

Thanks
 #54492  by ChrisW
 
Still working on it. To test, I did the following:
1. bin/tomcat stop
2. renamed the 6.3.12 .WAR file
3. removed work/Catalina/localhost
4. removed webapps/OpenKM
5. changed hibernate.hbm2ddl to update
6. copied the 6.3.11 .WAR file back
7. bin/tomcat start

6.3.11 started with no issue. I then went back and did the same process with 6.3.12 but it gave the same error (see attached).

One thing I noticed was the OpenKM directory started rebuilding immediately, even with tomcat stopped. Not sure it's even an issue.
Attachments
error.jpg
error.jpg (28.12 KiB) Viewed 520 times
 #54495  by ChrisW
 
Well, I got 6.3.12 working but not exactly sure how. Followed all the normal procedures (stop tomcat, remove directories, set to update, etc) but continued to get the sign-in error.

Took the drastic measure of removing the database, recreated the db using utf8 for the character set and utf8_unicode_ci for collation. Then I restored the db backup and let it assume the new character settings. Once that completed, did a bin/shutdown.sh, removed the directories, set the OpenKM.cfg to update, and restarted things using bin/startup.sh. Waited for everything to finish building and tried logging in. It started working!

NOTE: Tried using utf8mb4 but it would not even restore the database. The extra byte for the characters exceeded the length of the string fields. Would need to change some of them to blob types.
 #54504  by jllort
 
It is the first time I have seen this strange error in an upgrade. We do not suggest using utf8mb4 because the database will require space for the same kind of date ( not always but in most of the cases ).

About Us

OpenKM is part of the management software. A management software is a program that facilitates the accomplishment of administrative tasks. OpenKM is a document management system that allows you to manage business content and workflow in a more efficient way. Document managers guarantee data protection by establishing information security for business content.