• Rebuild checksum?

  • We tried to make OpenKM as intuitive as possible, but an advice is always welcome.
We tried to make OpenKM as intuitive as possible, but an advice is always welcome.
Forum rules: Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
 #53800  by thiagodalsoto
Hello, for some reason I don't know, I have a problem, at some point during an update the checksum stopped matching.
I have no problem using it because of this, noticed so far!

I searched the forum and couldn't find anything, how could I make the checksum sync again, in order to disappear this error when running the process in Utilities\Repository checker

Is there a rebuild checksum command?

reduced log
Code: Select all
Calculate number of nodes
Documents: 427
Folders: 184
Checking repository integrity
/okm:root/Manuais/Recursos Humanos/Edição/Apresentação PCC 2019.odp -> Checksum failure for node '6eab68a9-486f-4295-98b6-97c6b1c81ca2' and version '1.0'
/okm:root/Manuais/Recursos Humanos/Edição/Mudanças SAR 2020.odp -> Checksum failure for node '28366e0e-22be-4c33-ba15-77b1c7fa78cf' and version '1.0'
/okm:root/Manuais/Recursos Humanos/Edição/PCC VRA Revisado - 2020.odp -> Checksum failure for node '5341763d-551f-433f-beaa-106dce68cd8f' and version '1.1'

Repository check completed!

Path: /okm:root
Fast: true
Versions: true
Checkum: true

Documents: 0
Folders: 183
Size: 0 B
Time: 00:00:03
Version 6.3.11 build d7abb25

 #53816  by jllort
Have not much sense the checksum of the file changed. We keep the checksum because the application is able to verify nothing changed in the file system -> for example, disk corruption or similar issue. I suggest verifying your documents in the file system.
 #53817  by thiagodalsoto
Apparently nothing is corrupted, as I said we are using it perfectly.
I suspect this is all due to the fact that I did a fresh install, on a new server, restored the database backup and the local folder.

And in this case now, what would be the best way to solve this error that appears when I check the repository?


About Us

OpenKM is part of the management software. A management software is a program that facilitates the accomplishment of administrative tasks. OpenKM is a document management system that allows you to manage business content and workflow in a more efficient way. Document managers guarantee data protection by establishing information security for business content.