Unable to access swagger

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
Bharath
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Nov 01, 2018 10:07 am

Unable to access swagger

Post by Bharath » Thu Nov 01, 2018 10:30 am

I installed OpenKM in localhost. When i tried to access swagger using http://localhost:8080/OpenKM/services/r ... agger.json I got No service was found. Could you please help me out on this?

jllort
Moderator
Moderator
Posts: 10830
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Unable to access swagger

Post by jllort » Thu Nov 01, 2018 10:59 am

Did you checkout and compiled the last source code from GitHub master branch?
Are you using our OpenKM Development Environment?

Bharath
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Nov 01, 2018 10:07 am

Re: Unable to access swagger

Post by Bharath » Wed Dec 05, 2018 10:58 am

It is working for me now. Thank you Jllort

sas78776
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Jul 24, 2019 10:23 am

Re: Unable to access swagger

Post by sas78776 » Wed Jul 24, 2019 10:25 am

Can you please share the details how you got it working. I am facing the same issue of "No Service was found".

jllort
Moderator
Moderator
Posts: 10830
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Unable to access swagger

Post by jllort » Thu Jul 25, 2019 3:09 pm

What OpenKM version are you using? because Swagger.IO is only present from the latest 6.3.8

Post Reply