Running an Eclipse Created JBPM Project in JBPM Console

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
soujanyabargavi
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Sun Jul 01, 2018 3:01 am

Running an Eclipse Created JBPM Project in JBPM Console

Post by soujanyabargavi » Sun Jul 01, 2018 3:17 am

I'm using JBPM 6.0.1 and attempting to run the sample-->evaluation project in the jbpm-console.

The program runs fine in Eclipse, and has been pushed to a repository in jbpm-installer system. It shows in the JBPM Console's Explorer. However, none of the Java or process files(*.bpmn) files or items show.

Could someone please explain and/or point me to the right place in the documentation that will explain:

1.) How an Eclipse created project needs to be structured so it will be recognized by the console when accessed from the repository

2.) How a Java application can be run from the console.

jllort
Moderator
Moderator
Posts: 10169
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Running an Eclipse Created JBPM Project in JBPM Console

Post by jllort » Tue Jul 03, 2018 7:09 am

Should ask this question in a JBPM forum, because into OpenKM we are using older JBPM version what not works in the same way it does version 6.X

ulinuha
Fresh Boarder
Fresh Boarder
Posts: 7
Joined: Mon Nov 13, 2017 9:08 am

Re: Running an Eclipse Created JBPM Project in JBPM Console

Post by ulinuha » Wed Jul 11, 2018 4:51 am

Hello jllort,

I'm using Eclipse (Photon version) + JBPM3
However when i'm trying to deploy the workflow to openkm, in the development server setting there is no fields to configure user credential of openkm (username&password). That's why it won't connect & deploy the workflow to openkm server.
JBPM no auth.PNG
Is it because i'm using Eclipse instead of JBOSS 5?
Can you provide alternative link to JBOSS 5 since it's not found from the original website?
JBOSS not found.PNG
Thanks.

jllort
Moderator
Moderator
Posts: 10169
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Running an Eclipse Created JBPM Project in JBPM Console

Post by jllort » Fri Jul 13, 2018 3:58 pm

If you watch the video https://docs.openkm.com/kcenter/view/wf ... ances.html at 2:37 you will see are shown credential forms.

I suggest work with our development environment ( it is a VM -> 12GB what comes with everything -> eclipse and openkm ready to be used ) you can download from https://www.openkm.com/en/download.html

If you followed the steps described here https://docs.openkm.com/kcenter/view/wf ... lugin.html in your eclipse should also get it running, but I suggest the previous option, what sure will going right.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests