Problems running enviroment developer

He we will discuss about how to make customization and improvement to the OpenKM source code.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
albertogomez38
Junior Boarder
Junior Boarder
Posts: 20
Joined: Thu Jan 21, 2016 12:23 pm

Problems running enviroment developer

Post by albertogomez38 »

I have download de ova file.
Import de virtual machine.
Compile and created war file
Start openkm server.
But i cannot login...

Captura3.JPG
Captura4.JPG
Captura5.JPG
Please, ¿any idea where is the problem?
jllort
Moderator
Moderator
Posts: 11598
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problems running enviroment developer

Post by jllort »

Seems have created jar file either war file. In the project, you'll see a build.sh -> please execute it. Finally take a look at /home/openkm/development/tomcat/webapps -> should be an alias to openkm.war file
albertogomez38
Junior Boarder
Junior Boarder
Posts: 20
Joined: Thu Jan 21, 2016 12:23 pm

Re: Problems running enviroment developer

Post by albertogomez38 »

Thanks for the answer...

I add new captures..

But not work... then database is empty..

Captura6.JPG
Captura7.JPG
Captura8.JPG
jllort
Moderator
Moderator
Posts: 11598
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problems running enviroment developer

Post by jllort »

Try starting openkm from terminal:
* delete all files into the folder /home/openkm/Development/tomcat/logs/
* open a terminal and execute the next command line
sudo service openkm start

* take a look at /home/openkm/Development/tomcat/logs/openkm.log for errors in the startup

in case startup failed, please zip all files into logs folder and share here
1smael94
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Thu Oct 21, 2021 8:57 pm

Re: Problems running enviroment developer

Post by 1smael94 »

hi i have the same error, i download in the official site and i follow all steps for the implementation of this OVA but all time is the same error.
i think: ¿where i find other version of this ova functional? :cry: :cry: :cry:
pd: sorry for my bad english.
jllort
Moderator
Moderator
Posts: 11598
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problems running enviroment developer

Post by jllort »

Check if at /home/openkm/Development/tomcat/webapp have the the OpenKM.war file or OpenKM folder. In case do not have it, you must build the OpenKM project -> you have build.sh script ( run from terminal ) or build from eclipse.

The latest OVA does not come with OpenKM build, which will solve in the next releases of the OVA ( OVA is shared each time is released a new version of OpenKM, probably until the end of the year ).
Post Reply