installing from OKMInstaller.jar succeed, but cant launch

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
doniderawski
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Nov 04, 2020 4:14 am

installing from OKMInstaller.jar succeed, but cant launch

Post by doniderawski »

I have followed the video on youtube, but can't run http://localhost:8080/OpenKM

here's the issues :

Type Status Report

Message /OpenKM

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

When I do catalina.bat run, the error message is "Could not find or load main class Files\OpenKM\tomcat-8.5.34"

Please help...
jllort
Moderator
Moderator
Posts: 11512
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by jllort »

Seems you installed on Windows
* Ensure you have JDK version 1.8 ( with upper or lower version will not working )
* Ensure OpenKM service in windows is stopped
* Delete all the files into tomcat-XXXX/logs folder
* Open a terminal as administrator
* Go to tomcat-XXXX/bin folder and execute catalina.bat run ( do not close the terminal or press CTRL + C ) -> if it is shown started at the end it means the application is running ( do not close terminal you will kill the application ) -> check the browser

If do not success to get working share all the log folder here into ZIP
Gutkowski
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Apr 21, 2021 5:29 am

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by Gutkowski »

I tried to install java ( since I completely removed the older version). But whenever I click on it, the cursor just load a bit, then that's it. Nothing happens.

I tried to restart computer, turn off Firewall, all Offline Online Offlinex64, copy whatever Java installed from other pc, but didn't work at all. Seems like Window cant recognize copied version of Java though. Will it be Window 10's problem?



MyCCPay Portal
jllort
Moderator
Moderator
Posts: 11512
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by jllort »

Ensure you have create a variable named JAVA_HOME In your global environment variable what point to the c:\Program files\Java\jdkXXXXX\

1- with openkm stopped delete all the files into logs
2- Open the terminal and go into tomcat-XXX/bin and execute the command "catalina.bat run"
3- Share screenshot and openkm.log file ( do not press CTRL+C otherwise you are stopping the application )
wayangwong
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed May 19, 2021 12:54 pm

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by wayangwong »

Please help, this is my first time installing OpenKM Ver. 6.3.10 (Tomcat 8.5.34, Java version: 1.8.0_291, Mysql 8.0.25) on Windows 10.
OpenKM service installed successfully. But can not access http://localhost:8080/OpenKM. Then i run the catalina.bat and here's the log:

Code: Select all

2021-05-20 07:07:07,253 [localhost-startStop-1] INFO  com.openkm.module.db.DbAuthModule - Create okm:personal/system
2021-05-20 07:07:07,618 [localhost-startStop-1] INFO  com.openkm.module.db.DbAuthModule - Create okm:mail/system
2021-05-20 07:07:07,823 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Repository initialized ***
2021-05-20 07:07:07,823 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Cache deserialization ***
2021-05-20 07:07:08,027 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** User database initialized ***
2021-05-20 07:07:08,027 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Initializing workflow engine... ***
2021-05-20 07:07:08,035 [localhost-startStop-1] INFO  com.openkm.util.JBPMUtils - Creating JBPM default configuration
2021-05-20 07:07:08,152 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Initializing MIME types... ***
2021-05-20 07:07:08,380 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Activating update info ***
2021-05-20 07:07:08,391 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Activating cron ***
2021-05-20 07:07:08,393 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Activating UI Notification ***
2021-05-20 07:07:08,593 [localhost-startStop-1] INFO  c.o.module.common.CommonAuthModule - PrincipalAdapter: com.openkm.principal.DatabasePrincipalAdapter
2021-05-20 07:07:10,182 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Activating thesaurus repository ***
2021-05-20 07:07:10,199 [localhost-startStop-1] INFO  c.o.extension.core.ExtensionManager - Initialize and load plugins...
2021-05-20 07:07:10,409 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Execute start script ***
2021-05-20 07:07:10,429 [localhost-startStop-1] WARN  com.openkm.util.ExecutionUtils - Unable to read script: D:\DATA\14OpenKM\tomcat-8.5.34\start.bsh
2021-05-20 07:07:10,430 [localhost-startStop-1] WARN  com.openkm.util.ExecutionUtils - Unable to read jar: D:\DATA\14OpenKM\tomcat-8.5.34\start.jar
2021-05-20 07:07:10,431 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Execute start SQL ***
2021-05-20 07:07:10,436 [localhost-startStop-1] WARN  c.o.servlet.RepositoryStartupServlet - Unable to read sql: D:\DATA\14OpenKM\tomcat-8.5.34\start.sql
2021-05-20 07:07:10,448 [localhost-startStop-1] WARN  o.a.c.o.s.i.a.CmisAtomPubServlet - CMIS version is not defined! Setting it to CMIS 1.0.
2021-05-20 07:07:12,134 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down UI Notification... ***
2021-05-20 07:07:12,134 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down cron... ***
2021-05-20 07:07:12,136 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down update info... ***
2021-05-20 07:07:12,142 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting pending task executor... ***
2021-05-20 07:07:12,147 [localhost-startStop-1] INFO  c.o.u.pendtask.PendingTaskExecutor - ### All threads shutdown requested ###
2021-05-20 07:07:12,147 [localhost-startStop-1] INFO  c.o.u.pendtask.PendingTaskExecutor - ### All threads have finished ###
2021-05-20 07:07:12,148 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down repository... ***
2021-05-20 07:07:12,153 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Cache serialization ***
2021-05-20 07:07:12,181 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Repository shutted down ***
2021-05-20 07:07:12,182 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Execute stop script ***
2021-05-20 07:07:12,184 [localhost-startStop-1] WARN  com.openkm.util.ExecutionUtils - Unable to read script: D:\DATA\14OpenKM\tomcat-8.5.34\stop.bsh
2021-05-20 07:07:12,189 [localhost-startStop-1] WARN  com.openkm.util.ExecutionUtils - Unable to read jar: D:\DATA\14OpenKM\tomcat-8.5.34\stop.jar
2021-05-20 07:07:12,189 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Execute stop SQL ***
2021-05-20 07:07:12,190 [localhost-startStop-1] WARN  c.o.servlet.RepositoryStartupServlet - Unable to read sql: D:\DATA\14OpenKM\tomcat-8.5.34\stop.sql
2021-05-20 07:07:12,191 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down workflow engine... ***
2021-05-20 07:07:12,464 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Shutting down cache manager... ***
2021-05-20 07:07:12,500 [localhost-startStop-1] INFO  c.o.servlet.RepositoryStartupServlet - *** Hibernate shutdown ***
jllort
Moderator
Moderator
Posts: 11512
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by jllort »

The application seems started fine, but it is like you closed the terminal ( remember when starting application with "catalina.bat run", the application is executed in the command line and if you break it will be stopped ). Also you can try the command "catalina.bat start" and "catalina.bat stop" what works in a similar manner as a service executing the application in a secondary terminal.

From what I see in the log all seems fine.
wayangwong
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed May 19, 2021 12:54 pm

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by wayangwong »

Hi thank you for your reply,

When i try to start the service from windows services (OpenKM) -> it's started -> then i try to open http://localhost:8080/OpenKM -> but can't load the page -> when i check the OpenKM service, it is stop (i don't stop the service). Here i attach the catalina and openkm log.
Please help.
Attachments
OpenKM_logs.zip
(60.5 KiB) Downloaded 17 times
jllort
Moderator
Moderator
Posts: 11512
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by jllort »

It seems you have another tomcat or application using same port -> that's the reason why is not starting the service as expected.

Code: Select all

03-Jun-2021 06:56:08.730 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-127.0.0.1-8009"]
03-Jun-2021 06:56:08.745 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 72167 ms
03-Jun-2021 06:56:08.746 SEVERE [main] org.apache.catalina.core.StandardServer.await StandardServer.await: create[localhost:8005]: 
 java.net.BindException: Address already in use: JVM_Bind
	at java.net.TwoStacksPlainSocketImpl.socketBind(Native Method)
	at java.net.TwoStacksPlainSocketImpl.socketBind(TwoStacksPlainSocketImpl.java:133)
	at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:513)
	at java.net.TwoStacksPlainSocketImpl.bind(TwoStacksPlainSocketImpl.java:106)
	at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:180)
	at java.net.ServerSocket.bind(ServerSocket.java:375)
	at java.net.ServerSocket.<init>(ServerSocket.java:237)
	at org.apache.catalina.core.StandardServer.await(StandardServer.java:440)
	at org.apache.catalina.startup.Catalina.await(Catalina.java:769)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:715)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:353)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:493)
Two options:
* find application what it is using the same ports and stop
* change current openkm tomcat ports -> may be the easiest -> take a look at https://docs.openkm.com/kcenter/view/ok ... -port.html
wayangwong
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed May 19, 2021 12:54 pm

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by wayangwong »

Oh great!! Thank you very much, it works now.. :)
spiceagent11
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Fri Jun 18, 2021 7:21 pm

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by spiceagent11 »

I tried to restart computer, turn off Firewall, all Offline Online Offlinex64, copy whatever Java installed from other pc, but didn't work at all. Seems like Window cant recognize copied version of Java though. Will it be Window 10's problem?
jllort
Moderator
Moderator
Posts: 11512
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: installing from OKMInstaller.jar succeed, but cant launch

Post by jllort »

* Ensure OpenKM is stopped
* Delete all files in the tomcat-XXX/log folder
* Start OpenKM
* Zip logs files and share here
Post Reply