OpenKM.ear is not generated

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
stargaizer
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Wed Apr 30, 2008 8:49 am
Location: Germany
Contact:

OpenKM.ear is not generated

Post by stargaizer » Fri Feb 13, 2009 10:23 am

Hello,

i try to setup an OpenKM develeopement environment as described in the documentation. I use a fresh Eclipse Europa installation, JBoss Tools 1.1.2 and JBoss 4.2.2 under Debian Etch.
The OpenKM.ear file wasn\'t automaticly generatet. And if i try a \"Build archive (full)\" in the \"Project archives\" view, i get an error:

An internal error occurred during: \"Build Archive Node\".
java.lang.NullPointerException

I\'ve try\'d this with Java 1.5 and 1.6.

Matthias

jllort
Moderator
Moderator
Posts: 10830
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re:OpenKM.ear is not generated

Post by jllort » Sat Feb 14, 2009 8:34 pm

Install this version of jboss tools.

Before doing it remove actual jboss tools installation. ( if you\'ve merged files to eclipse/plugins directory you\'ll need to reinstall eclipse, don\'t merge, I suggest other way to install plugins as a links on external directories and execute \"eclipse -clean\" refreshing initial eclipse configuration each time you need, but I don\'t know which is your case. )
-------------------------------------------------
OpenKM Team ( be open my friend )
http://www.openkm.com

Post Reply