Problemas con instalacion?

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
killmasta93
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Tue Feb 18, 2020 1:58 pm

Problemas con instalacion?

Post by killmasta93 »

Hola,
Quería saber si me podrían dar luz al problema que tengo, Estoy instalando la versión mas nueva de openkm, cuando ya termino instalando me sale esto

Class: org.apache.jasper.JasperException
Message: javax.servlet.ServletException: com.openkm.core.DatabaseException: Cannot open connection
Date: Tue Feb 18 08:55:32 COT 2020

eso es el cfg

Code: Select all

# OpenKM Hibernate configuration values
hibernate.dialect=org.hibernate.dialect.MySQL5InnoDBDialect
hibernate.hbm2ddl=none

# Logback configuration file
logback.config=logback.xml
y el otro el xml

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<beans:beans xmlns:beans="http://www.springframework.org/schema/beans"
             xmlns:security="http://www.springframework.org/schema/security"
             xmlns:task="http://www.springframework.org/schema/task"
             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xmlns:amq="http://activemq.apache.org/schema/core"
             xsi:schemaLocation="http://www.springframework.org/schema/beans
                                 http://www.springframework.org/schema/beans/spring-beans.xsd
                                 http://www.springframework.org/schema/security
                                 http://www.springframework.org/schema/security/spring-security.xsd
                                 http://www.springframework.org/schema/task
                                 http://www.springframework.org/schema/task/spring-task.xsd">

<!-- Security configuration -->
<security:authentication-manager alias="authenticationManager">
  <security:authentication-provider>
    <security:password-encoder hash="md5"/>
    <security:jdbc-user-service 
        data-source-ref="dataSource"
        users-by-username-query="select usr_id, usr_password, 1 from OKM_USER where usr_id=? and usr_active='T'"
        authorities-by-username-query="select ur_user, ur_role from OKM_USER_ROLE where ur_user=?"/>
  </security:authentication-provider>
</security:authentication-manager>

</beans:beans>

gracias

jllort
Moderator
Moderator
Posts: 11162
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problemas con instalacion?

Post by jllort »

1- Las credenciales de la base de datos la tienes en el fichero server.xml ( dentro de $TOMCAT_HOME/conf ).

Asegúrate que desde este servidor puedes conectar contra la base de datos. Pruébalo desde la terminal ( Linux ) o desde el workbench ( Windows ), porque en un 99% el problema lo tienes ahi.

Información adicional aquí : https://docs.openkm.com/kcenter/view/ok ... riadb.html

brauliopena
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Mar 09, 2020 12:35 pm

Re: Problemas con instalacion?

Post by brauliopena »

He tratado de instalar OpenKM según el video paso a paso, sin resultados positivos.
Ambiente:
1. Windows 2012 R2
2. Java SE (JDK 8u241-windows-x64
3. OpenKM.jar (6.3.8 y 6.3.9)
4. MySql-Installer-community-8.0.19.0

Primero: no me instala servicio de tomcat y/o apache sino, un servicio
llamado OpenKM
Segundo: al completar la instalación no tengo acceso a ningúna pagina
localhost:8080/openkm (como es lógico por no tener un servicioweb o html
como apache o II)

Si alguien ha tenido éxito en esta y/o tiene las versiones para descargar
que si funcionan OpenKM.jar (6.3.3)?

jllort
Moderator
Moderator
Posts: 11162
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problemas con instalacion?

Post by jllort »

Yo te aconsejaría haber abierto un post por separado ... porque tus problemas no tienen mucho que ver con el usuario anterior. Efectivamente te va a crear un servicio de windows llamado OpenKM que es el que tienes que arrancar.

Tienes un fichero en la carpeta de tomcatXXXX/logs tienes un catalina.log ( si no te arranca la aplicación súbelo en este post )

La url es localhost:8080/OpenKM ( con la O, K, M en mayúsculas, el contexto es case sensitive )

Y finalmente la aplicación viene con un tomcat, no con un service web apache o IIS ( por defecto el tomcat arrancado utilizará el puerto 8080 y si lo tienes ocupado será otra razón que te aparecerá en el log de porque la aplicación no te está arrancando )

Post Reply