Problemas previsualización con versión 6.3.10

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
dpm2021
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jul 01, 2021 3:10 pm

Problemas previsualización con versión 6.3.10

Post by dpm2021 »

Buenas tardes:
Estoy trabajando en la instalación de OpenKM, versión de la Comunidad 6.3.10, sobre plataforma Windows (Server 2019) y observo que la previsualización de documentos de Microsoft Office (Word y Excel) no funciona.
La documentación que he consultado indica que la clave system.openoffice.path debe estar correctamente configurada, pero no la encuentro en esta versión.
¿Alguien se ha encontrado con este mismo problema?
Gracias de antemano y un saludo.
dpm2021
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jul 01, 2021 3:10 pm

Re: Problemas previsualización con versión 6.3.10

Post by dpm2021 »

Por lo que he podido comprobar, si se hace una instalación limpia de la versión 6.3.10 el problema que impide la previsualización no puede corregirse porque falta la clave system.openoffice.path.
Sin embargo, si se hace una instalación limpia de la versión 6.3.9, la clave system.openoffice.path aparece, por lo que puede informarse con C:\tomcat-8.5.34\extras\LibreOfficePortable\App, lo que posibilita el que la previsualización funcione de forma correcta.
Una vez instalada la versión 6.3.9 con la configuración de previsualización correcta, se pueden aplicar las actualizaciones 6.3.10 y 6.3.11 y la previsualización funciona correctamente.
Un saludo.
jllort
Moderator
Moderator
Posts: 11570
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problemas previsualización con versión 6.3.10

Post by jllort »

Quick question for 6.3.10 and upper:
* Installation have been done in windows?
* Confirm the extras folder exist in tomcat folder?
* Problem is the configuration parameter is not set automatically with the right path?
pavila
Moderator
Moderator
Posts: 3114
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Problemas previsualización con versión 6.3.10

Post by pavila »

Por favor, descarga el instalador de nuevo y prueba a instalar. Ahora debería aparecer la propiedad de configuración en el fichero OpenKM.cfg

Un saludo.
dpm2021
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jul 01, 2021 3:10 pm

Re: Problemas previsualización con versión 6.3.10

Post by dpm2021 »

Hi, Pavila:
Yes, with the new installer the preview works correctly.
Thank you.
pavila
Moderator
Moderator
Posts: 3114
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Problemas previsualización con versión 6.3.10

Post by pavila »

Great :)
Post Reply