Page 1 of 1

Community Edition not running after installation

PostPosted:Wed Oct 07, 2020 6:11 am
by KKSharma
I have tried the installation of CE by two different methods separately on two machines.
1. By using OKMInstaller.jar file
2. By extracting both OpenKM (Zipped folder) as well as Tomcat 8.5 (Zipped folder) under C: (root) directory
and done changes under the Tomcat Server files accordingly.

But in both ways, the tomcat service is not running up showing error message:

Windows could not start the Apache Tomcat 8.5 Tomcat8 on Local Computer.
For more information, review the System Event Log. If this is a non-Microsoft service,
contact the service vendor, and refer to service specific error code 4.


Then I googled the solution of tomcat. bypass the Java path and set to default then also same error.

Any solution please. Thanks.

Re: Community Edition not running after installation

PostPosted:Fri Oct 09, 2020 6:29 am
by jllort
Try starting from command like, go into bin folder and execute "catalina.bat run" ( do not close the console ). From there it is working?
Sure you have installed JAVA JDK 1.8, either will not work.

Re: Community Edition not running after installation

PostPosted:Sun Oct 11, 2020 10:49 am
by KKSharma
Thanks Mr. Jllort for the response.

But still I am struggling despite followed all the instructions carefully.

1. Catalina.bat run -> is closing the console automatically and showing error with database connection.

2. When I open the http://localhost:8080/OpenKM/login.jsp
the below:
Application error
Class: org.apache.jasper.JasperException
Message: An exception occurred processing JSP page [/login_desktop.jsp] at line [230] 227:
Date: Sun Oct 11 14:21:46 GST 2020


For this error I have searched the similar post where it is mentioned that need to change the Legacy option for Mysql Root Password. I have selected the selected option and reset the root password, but not working.

Kindly provide the solution. Thank you very much.

Re: Community Edition not running after installation

PostPosted:Wed Oct 14, 2020 7:42 am
by jllort
Problem comes with database connection. Check server.xml values, check user / password, basically check database connection what seems is not working.
What database did you configured? MySQL?

Maybe this documentation section will help https://docs.openkm.com/kcenter/view/ok ... oting.html