NB: JAVA_HOME should point to a JDK not a JRE

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
Caronte
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Tue Dec 11, 2018 1:44 pm

NB: JAVA_HOME should point to a JDK not a JRE

Post by Caronte » Sat Dec 22, 2018 2:19 am

Utilizando;
-Windows 10
-Tomcat:8.5.24
-JDK:11.0.1

Luego de realizar todos los procedimientos usuales (recomendados*video) para la instalación de Open KM - Comunity
no se localiza el servicio de Tomcat para activación, no se logra activar por MySQL y no es posible acceder a Open KM.

"mensaje en la consola luego de instalar servicios"

The JAVA_HOME environment variable is not defined correctly
This environment variable is needed to run this program
NB: JAVA_HOME should point to a JDK not a JRE
- Directory cleanup
- Don't forget to create the database
CREATE DATABASE okmdb DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_bin;
CREATE USER openkm@localhost IDENTIFIED BY 'lWtUxmycG91i';
GRANT ALL ON okmdb.* TO openkm@localhost WITH GRANT OPTION;

La variable: JAVA_HOME se tiene por bien definida (verificada en múltiple ocasiones)


- si es posible y es clara la exposición de los datos del problema, se agradece ayuda al respecto.

Gracias.

jllort
Moderator
Moderator
Posts: 10830
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: NB: JAVA_HOME should point to a JDK not a JRE

Post by jllort » Mon Dec 24, 2018 3:39 pm

El error es claro, no tienes la variable JAVA_HOME bien definida:
1- o bien la añades en las variables de entorno
2- o bien abres la terminal y escribes algo asi como
set JAVA_HOME=c:\Program files\Java\jdk_1XXXXX ( la versión que corresponda ).

Te aconsejamos que mires con calma este video:
https://www.youtube.com/watch?v=6F7Hany7BMc

Post Reply