• Error Previsualizar Community version 6.3.3

  • OpenKM tiene muchas características interesantes, pero es necesario un proceso de configuración para mostrar todo su potencial.
OpenKM tiene muchas características interesantes, pero es necesario un proceso de configuración para mostrar todo su potencial.
Forum rules: Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
 #43644  by gcosta
 
Buenos días, hemos realizado la migración de la versión Community 6.3.2 a la 6.3.3 siguiendo los pasos del manual.

Todo ha ido bien excepto que no podemos previsualizar los documentos.

Licence key not accepted (no key passed to viewer)
Obtain a licence from http://flexpaper.devaldi.com/

He visto que ha alguien más ya le ha sucedio pero no tenemos solucion.

Gracias.
Attachments
PrtScr capture.jpg
PrtScr capture.jpg (216.7 KiB) Viewed 6195 times
 #43655  by jllort
 
A ver si esto soluciona algo, porque yo lo he probado localmente y me funciona.
- Para la aplicación
- Elimina las carpetas webapps/OpenKM y work/Catalina/localhost
- Asegurate de que ha limpiado la cache del navegador
- Arranca la aplicacion
- En los profiles asegurate que la funcion de print esta activa
- Refresca el UI
- Intenta visualizar un pdf
 #43679  by gcosta
 
Buenas tardes, gracias por la respuest.

He seguido los pasos y sigue igual no funciona. Me fijado que no puedo previsualizar ningún fichero tipo office o pdf. En cambio ficheros tipo txt, sql ,...
los lee bien.

Me da el error de licencia mostrado en la imagen anterior.

Haber si alguien puede echarme un cable.

Gracias.
 #43684  by sgarcia
 
Yo tengo el mismo problema con la versión Community en "modo producción"

Sin embargo con la misma versión cargada en el entorno de desarrollo y lanzada desde Eclipse me va bien... :lol:

No he investigado mas porque tengo una cola larga de cosas que probar....., pero en breve me pondre a ello

Saludos
 #43704  by jllort
 
Hemos sido capaces de reproducir el problema, pero aún no lo tenemos solucionado, espero que para la semana próxima ya lo tengamos solucionado. Las caches de los navegadores, esas grandes amigas que te engañan y te muestran cosas que no son.
 #43862  by gcosta
 
Perfecto gracias. El proceso de actualización és mejor actualizar primero a 6.3.3 y posteriormente a la 6.3.4 o se puede actualizar directamente a la 6.3.2 a 6.3.4?

Gracias.
 #43869  by jllort
 
Siempre es mejor subir de version a version. El proceso en el que nosotros nos esforzamos en verificar que funciona correctamente es entre versiones. Piensa que hay veces en que entre versiones se realizan cambio de base de datos ( hibernate lo hace automáticamente normalmente ) y nosotros sabes que entre un salto simple esto siempre te funcionará bien, pero igual con N saltos ya no. Nuestra recomendación siempre va a ser subir poco a poco.

A medio plazo, igual que tenemos en la profesional, vamos a liberar una herramienta para que el proceso de actualización sea totalmente automático.
 #44359  by gcosta
 
Buenas tardes, acabo de proceder a realizar el upgrade de la versión community 6.3.2 a 6.3.3 y por último a la 6.3.4 para solventar el problema de la previsualización.

El problema es que el OpenKM.war de la versión 6.3.4 no carga bien. Da error por lo que no puedo realizar el upgrade de la community 6.3.3 a 6.3.4.

Adjunto catalina.log en el moment de arrancar el servidor OpenKM
Code: Select all
2017-07-18 16:18:19,165 [pool-2-thread-1] INFO  org.apache.catalina.loader.WebappClassLoader - validateJarFile(/opt/openkm-6.2.5-community/tomcat/webapps/OpenKM/WEB-INF/lib/servlet-api-2.5-20081211.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
2017-07-18 16:18:19,166 [pool-2-thread-1] INFO  org.apache.catalina.loader.WebappClassLoader - validateJarFile(/opt/openkm-6.2.5-community/tomcat/webapps/OpenKM/WEB-INF/lib/servlet-api-6.0.36.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
2017-07-18 16:20:51,178 [pool-1-thread-1] ERROR org.apache.catalina.startup.HostConfig - Error waiting for multi-thread deployment of WAR files to complete
java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: Java heap space
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:751)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:471)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1416)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:312)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
	at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
	at org.apache.catalina.util.LifecycleBase.setStateInternal(LifecycleBase.java:401)
	at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:346)
	at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:1145)
	at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:782)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1566)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1556)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.OutOfMemoryError: Java heap space
	at org.apache.tomcat.util.bcel.classfile.Constant.readConstant(Constant.java:129)
	at org.apache.tomcat.util.bcel.classfile.ConstantPool.<init>(ConstantPool.java:60)
	at org.apache.tomcat.util.bcel.classfile.ClassParser.readConstantPool(ClassParser.java:209)
	at org.apache.tomcat.util.bcel.classfile.ClassParser.parse(ClassParser.java:119)
	at org.apache.catalina.startup.ContextConfig.processAnnotationsStream(ContextConfig.java:2032)
	at org.apache.catalina.startup.ContextConfig.processAnnotationsJar(ContextConfig.java:1923)
	at org.apache.catalina.startup.ContextConfig.processAnnotationsUrl(ContextConfig.java:1891)
	at org.apache.catalina.startup.ContextConfig.processAnnotations(ContextConfig.java:1877)
	at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1270)
	at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:855)
	at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:345)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
	at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5161)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:895)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:871)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:615)
	at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:962)
	at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1603)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	... 4 more
 #44373  by jllort
 
Yo diria que estas ejecutando el OpenKM con una version de jdk 1.7 y por eso te esta dando el error de heap. Yo probaría a instalar el jdk 1.8 y asegúrate de que estas arrancando con este jdk.

Veo que estas con linux, puedes poner el JAVA_HOME dentro del setenv.sh para asegurarte de que arranca con el jdk 1.8. Una vez confirmado que te arranca bien con el jdk 1.8 te aconsejamos eliminar el antiguo 1.7
 #44380  by gcosta
 
Buenas tardes, si trabajo con la versión 1.8 de java tengo muchos problemas. errores y cortes de comunicacion con el OpenKm.

Que version es la más adecuada de java?

Gracias.

About Us

OpenKM is part of the management software. A management software is a program that facilitates the accomplishment of administrative tasks. OpenKM is a document management system that allows you to manage business content and workflow in a more efficient way. Document managers guarantee data protection by establishing information security for business content.