Page 1 of 1

Error in document create API

Posted: Tue Sep 03, 2019 1:01 pm
by openkm_user
Hi all,

We recently upgraded OpenKM Community version from 6.3.3 to 6.3.8, since we mostly use OpenKM API we upgraded SDK to 1.2 as well. Search seems to be working good after making some changes, but creating document throws error.

error.JPG

Please help!

Re: Error in document create API

Posted: Tue Sep 03, 2019 1:27 pm
by openkm_user
Looks like the issue is because of the Automation Rules, I have created 50+ rules and using the same (same database) in 6.3.8, but whenever I try to open an Automation Rule filter, it shows,

error.JPG

How to fix this?

Re: Error in document create API

Posted: Thu Sep 05, 2019 7:10 pm
by jllort
Should migrate automation rules, now are not registered in database, are registered as plugins. Take a look here:
https://docs.openkm.com/kcenter/view/ok ... ction.html
https://docs.openkm.com/kcenter/view/ok ... ation.html

In the migration guide section what talks about 6.3.6 to 6.3.7 it is explained this change:
https://docs.openkm.com/kcenter/view/ok ... o-637.html