Page 1 of 1

Search the document properties or notes does not work

Posted: Thu Jan 10, 2019 4:17 pm
by leemccarthyn
Maybe someone can help me with this.

Am using OpenKM 6.3.6 (fresh install) on a Windows 10 workstation (also new install). I access OpenKM using Google Chrome.

For the record, I installed OpenKM because the problem I'm having below did NOT occur when I ran a few tests on the online site, which is version 6.4.41. Not sure if that makes a difference.....

Anyway, my installation was successful, login fine. Added a few documents, gave them keywords and added some notes to each of them so that I can search by notes or by keyword.

Now here's the problem. if I try to do a search for any of the words that I have added within the notes tab, no luck, not found. If I try to search by file name, same problem. Nothing found. If I try to search by Keyword, that does work. It will also search within the document, but that doesn't help me as most of the docs that I have aren't readable and haven't been OCR'ed. I have tried rebuilding the indexes under Administration --> Utilities, no luck.

Is there some configuration that needs to be done to allow it to search the Notes tab or to search the filename?

Thanks all in advance.

Re: Search the document properties or notes does not work

Posted: Fri Jan 11, 2019 5:54 pm
by jllort
Let's go step by step:
1- First community version 6.3.x is not 6.4.41 professional ( if you have professional version installed with an issue into should adding a support ticket for it )
2- Lets start with basic search:
- By document name
- By keyword
- I think notes search is not supported in community edition, if there's not a field named notes then sure is not supported.

Share with us an screenshot for search by document name and keword ( search and desktop view to compare )