DATABASE

We tried to make OpenKM as intuitive as possible, but an advice is always welcome.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
virgo29
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Sat Mar 04, 2017 10:46 am

DATABASE

Post by virgo29 » Sat Mar 04, 2017 10:54 am

Hi,

Any one could help me, I accidentally drop my database "okmdb" without backup on it.

actually im doing this procedure HSQLdb to MySQLdb but when i get in this Steps "CREATE USER openkm@localhost IDENTIFIED BY '*secret*';" it shows error "error 1064(42000): You have an error in your SQL syntax; check the manual that corresponds to your MYSQL server version for the right syntax to use near '8080/OpenKM with grant option' at line 1"

what i imputed here is "CREATE USER openkm@121.58.251.214 IDENTIFIED BY '*secret*';

so when i shows the table it says empty then i cannot access already the openKM.


Urgent need your assistance.

Thanks

jllort
Moderator
Moderator
Posts: 9119
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: DATABASE

Post by jllort » Sat Mar 04, 2017 11:16 am

Should be something like it ( must be execute from mysql database client not from OpenKM database client, you are still not connected to MySQL from there):

Code: Select all

CREATE DATABASE okmdb DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_bin;
CREATE USER openkm@localhost IDENTIFIED BY 'password';
GRANT ALL ON okmdb.* TO openkm@localhost WITH GRANT OPTION;

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest