Enabling and using extension properly

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
aleifuu
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Wed Aug 08, 2018 3:39 am

Enabling and using extension properly

Post by aleifuu » Tue Aug 14, 2018 12:22 pm

Hi team, my version is OpenKM 6.3 community version. Have had it running well for few days now. I'm impressed so far on how much more you can organize /w OpenKM

One of useful features that I just learned is that there are few OpenKM that you can enable. By following the doc here:
https://docs.openkm.com/kcenter/view/ok ... sions.html

It's just a matter of running some SQL statement. easy enough I thought

I have also made sure that these extensions are activated for the current user profile, however I'm having no luck with seeing these extensions in action even after logging out and restart the server. No useful log that I can see so far

Only Workflow tab appears. I was expecting to bring Wiki/Forum extension to work. But I don't see them anywhere or have found way to get them to appear

Any ideas ?
Will appreciate it a lot

jllort
Moderator
Moderator
Posts: 10267
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Enabling and using extension properly

Post by jllort » Thu Aug 16, 2018 11:25 am

Two possibilities, you are not using the profile you have modified or you have not marked the extension before clickin on edit button. Some screenshots below what might help you.
support_344.png
support_345.png

aleifuu
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Wed Aug 08, 2018 3:39 am

Re: Enabling and using extension properly

Post by aleifuu » Fri Aug 17, 2018 6:38 am

I'm sure I did. Let me get a screenshot here when I have more time later on

Cheers,

aleifuu
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Wed Aug 08, 2018 3:39 am

Re: Enabling and using extension properly

Post by aleifuu » Fri Aug 17, 2018 7:38 am

Hi jilort, here we go

I have made sure I logged out from Administrator account and log back in
Attachments
Screenshot 2018-08-17 at 14.34.19.png
Screenshot 2018-08-17 at 14.33.36.png

jllort
Moderator
Moderator
Posts: 10267
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Enabling and using extension properly

Post by jllort » Sun Aug 19, 2018 7:14 am

Ensure the user who's logged have assigned the profile named default ( what is the profile you are modifying ). Should working. Also I suggest you use the version 6.3.6 ( the latest ).

aleifuu
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Wed Aug 08, 2018 3:39 am

Re: Enabling and using extension properly

Post by aleifuu » Mon Aug 20, 2018 5:17 am

Yeah, i think let me just upgrade to 6.3.6 first and we'll see from there

Cheers,

aleifuu
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Wed Aug 08, 2018 3:39 am

Re: Enabling and using extension properly

Post by aleifuu » Tue Aug 21, 2018 3:00 am

Hi @jilort,

Yes finally. upgrading to 6.3.6 make extensions work

I followed migration guide from the docs :
https://docs.openkm.com/kcenter/view/ok ... guide.html
and have made necessary changes to MySQL backend

I'm still using the bundled Tomcat community version as of now

Wiki extension works ! yes

Forum extension ... doesn't quite work yet ( see attached )

Error when communicating with Server (createTopic)

Excerpt from catalina.log

Code: Select all

607	2018-08-21 02:58:05,998 [http-bio-0.0.0.0-8080-exec-7] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/OpenKM]- Exception while dispatching incoming RPC call
608	com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract com.openkm.frontend.client.bean.extension.GWTForumTopic com.openkm.extension.frontend.client.service.OKMForumService.createTopic(long,java.lang.String,com.openkm.frontend.client.bean.extension.GWTForumTopic) throws com.openkm.frontend.client.OKMException' threw an unexpected exception: java.lang.NullPointerException
609	at com.google.gwt.user.server.rpc.RPC.encodeResponseForFailure(RPC.java:385)
610	at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:588)
611	at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:208)
612	at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(RemoteServiceServlet.java:248)
613	at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(AbstractRemoteServiceServlet.java:62)
614	at javax.servlet.http.HttpServlet.service(HttpServlet.java:646)
615	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
616	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
617	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
618	at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
619	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
620	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
Attachments
Screenshot 2018-08-21 at 09.58.17.png

jllort
Moderator
Moderator
Posts: 10267
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Enabling and using extension properly

Post by jllort » Thu Aug 23, 2018 8:52 am

For the Forum issue add an issue here with detailed error description https://github.com/openkm/document-mana ... tem/issues

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests