Joomla explorer connection fails

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
silverspr
Senior Boarder
Senior Boarder
Posts: 75
Joined: Thu Aug 21, 2014 12:58 pm

Joomla explorer connection fails

Post by silverspr » Tue Mar 13, 2018 4:52 am

HI, Joomla explorer works connecting to OpenKM installed on the same server as website i.e. http://localhost:8080/OpenKM. But if I attempt to connect to OpenKM thru JE if OpenKM is not stalled to the same server as the website i.e. http://123.123.36.49:8080/OpenKM, the connection fails. If the URL is opened outside JE, the URL (OpenKM) works as expected.

Will JE only work if OpenKm is installed to the same server as the hosting website?
jeip.PNG
connection fails
jeip.PNG (5.21 KiB) Viewed 518 times

jllort
Moderator
Moderator
Posts: 10169
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Joomla explorer connection fails

Post by jllort » Thu Mar 15, 2018 7:54 pm

Try ending the url with "/" might be we have some issue building the url

silverspr
Senior Boarder
Senior Boarder
Posts: 75
Joined: Thu Aug 21, 2014 12:58 pm

Re: Joomla explorer connection fails

Post by silverspr » Thu Mar 15, 2018 10:32 pm

Hi, thanks
Tried your suggestion, although the "/" was entered, the app doesn't save the closing slash "/". After updating and saving the configuration, went back and checked, the "/" wasn't saved. The problem persists JE unable to connect to a server external to the website.

thanks
d

silverspr
Senior Boarder
Senior Boarder
Posts: 75
Joined: Thu Aug 21, 2014 12:58 pm

Re: Joomla explorer connection fails

Post by silverspr » Tue Jul 03, 2018 8:12 pm

I have an externally hosted website where I would like to use joomla explorer to connect to openKM on a remote server. For instance, I am not able to connect to openKM if I use a link to my home server from the hosted website. https://123.123.36.49:8080/OpenKM FYI, the same link works from my mobile phone.

I am able to connect in my test environment where the both the website and openKM are hosted on the same server.
https://localhost:8080/OpenKM

thanks again
CE 6.3.5 dev
JE 2.09

jllort
Moderator
Moderator
Posts: 10169
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Joomla explorer connection fails

Post by jllort » Fri Jul 06, 2018 8:08 am

Is quite strange you can not connect from desktop but can connect from mobile. You desktop is in the same network of the server ? in this case you should use internal IP rather than public IP. Anyway seems networking issue not OpenKM one.

silverspr
Senior Boarder
Senior Boarder
Posts: 75
Joined: Thu Aug 21, 2014 12:58 pm

Re: Joomla explorer connection fails

Post by silverspr » Sun Jul 15, 2018 5:54 pm

I forgot to mention if I embed the link: http://123.123.36.49:8080/OpenKM on the hosting website the link works. Only joomla explorer throws a connection error using the same link. Attached are the server logs from the hosting website:
hosting_errors.JPG
hosting website errors
Attached administrator php file referenced above:
adminphp.7z
admin.php
(927 Bytes) Downloaded 4 times
FYI Both the hosting website and the server the link points to are running php 7.0. I'm no expert in this area, is it a problem with php versions?
I don't think its a network issue.
thanks

sochoa
Junior Boarder
Junior Boarder
Posts: 37
Joined: Thu May 02, 2013 3:26 am

Re: Joomla explorer connection fails

Post by sochoa » Mon Jul 16, 2018 6:20 pm

Hi.
Perform tests from a local machine and also from a local network and also probe from an external server and works well
Conduct the tests with:

openkm-6.3.6
php 5
php7.0.30
php7.1.6-2

joomla3.8.10

I pass a new version of joomla-explorer
regards

https://drive.google.com/open?id=1sn1UZ ... tu_6X7RWEU

silverspr
Senior Boarder
Senior Boarder
Posts: 75
Joined: Thu Aug 21, 2014 12:58 pm

Re: Joomla explorer connection fails

Post by silverspr » Mon Jul 16, 2018 8:52 pm

HI sochoa
thank you, Eureka...I have it working, I had to change the port I was forwarding on, but it is working.
Thanks for your help.

now the mime type is not set correctly...I will open another thread.
d

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests