ROLE_USER group modify

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
gennari
Fresh Boarder
Fresh Boarder
Posts: 10
Joined: Tue Jan 02, 2018 3:41 pm

ROLE_USER group modify

Post by gennari » Tue Jan 02, 2018 3:55 pm

Hi there,
I am testing OpneKM 6.3.4 with Active Direcotory authentication. I would like to use not default groups name, so I successfully changed ROLE_ADMIN in OKM_ADMIN and user of this AD group can login and administer without problems.

I am trying to do same thing with ROLE_USER, I wuold like to change it in OKM_USER>

I created a row in okm_role table
I changed default.user.role property
I changed webapps/OpenKM/WEB-INF/appContext.xml with this row <beans:property name="rolePrefix" value="OKM_"/>
in openkm.log I can find this:

Code: Select all

logs/openkm.log:2018-01-02 16:40:09,874 [localhost-startStop-1] [] INFO  com.openkm.core.Config - RELOAD - default.user.role=OKM_USER
But if I try to log with a user in AD group OKM_USER I get this error:

Code: Select all

com.openkm.core.RepositoryException: PathNotFoundException: 52fd6d8c-993c-4f52-b7d8-488a60b29832 : /okm:trash

If I put user in ROLE_USER AD group, he can log-in. For me it is very strange.

Can you help me please?

Thanks in advance.

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: ROLE_USER group modify

Post by jllort » Wed Jan 03, 2018 4:21 pm

Try to authenticate as super user -> if you do not get any error from this scenario then try with standard user ( ROLE_USER or in your case OKM_USER ), if you have some issue ( might be ) then you need to update values into the table OKM_NODE_ROLE_PERMISSION

something like:

Code: Select all

update OKM_NODE_ROLE_PERMISSION set NRP_ROLE='OKM_USER' where NRP_ROLE='ROLE_USER';
Finally you must reindex the lucene search engine -> Administration > tools > rebuild indexes -> choose Lucene indexes

Remember to change the configuration parameter named default.user.role

gennari
Fresh Boarder
Fresh Boarder
Posts: 10
Joined: Tue Jan 02, 2018 3:41 pm

Re: ROLE_USER group modify

Post by gennari » Thu Jan 04, 2018 8:31 am

Ok,
it is working done!

Thank you very much.

genna

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests