Baffling Preview Problem - Works in some browsers, not in others.

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
SirFancyWeaselbocker
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Tue Jan 24, 2017 12:31 am

Baffling Preview Problem - Works in some browsers, not in others.

Post by SirFancyWeaselbocker » Tue Jan 24, 2017 12:45 am

Greetings.

I have a baffling problem with my OpenKM 6.3.1 (build: 8235) on my CentOS Linux release 7.3.1611 (Core) server.

I cannot get anything to load in my preview tab on Firefox or Internet Explorer on multiple machines. The VAST majority of my files are PDF's. With the NPAPI situation being what it is, that's what I have to use.

However, if I load Chrome or a browser that does not support NPAPI, the preview tab works perfectly. Any file type loads up in seconds.

I've replicated this on a Windows 10 machine, 2008R2 server and on Windows 8.1.

So, presently I'm using one browser to do uploads and another to do previews. I've been operating like this for quite some time, however I have new users coming online next week and I'm hoping to get to the bottom of this quirk and get myself figured out.

Thoughts? Suggestions?

Thanks,
SirFancyW.

jllort
Moderator
Moderator
Posts: 9380
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by jllort » Wed Jan 25, 2017 1:04 pm

I do not understanding the relation with NPAPI support ( what has been removed in latest chrome versions ) and documents preview. Can you make a screnshot of the first tab in the default profile.

Also at Administration > configuration parameters which is the value of system.previewer parameter

Do you have adobe flash player support in chrome ?

Make some screenshot in browsers where preview tab is not shown.

prachueb
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed Feb 01, 2017 3:00 am

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by prachueb » Wed Feb 01, 2017 3:18 am

Me too.
I using Ubuntu 16.04.1 server with OpenKM 6.3.1 as server.

I try to browse the pdf file preview from the client connection.
- Ubuntu 16.04.1 Desktop
- Chrome with flash installation (with warning form OpenKM about not support for Scanner and Uploader): no Preview appear but the status told that "Starting conversion" and still there, nothing show.
- Firefox with Java installation (no warning from OpenKM about not support for Scanner and Uploader): no Preview appear but the status told that "Starting conversion" and still there, nothing show.

- MS Windows 7
- Chrome with flash installation (with warning form OpenKM about not support for Scanner and Uploader): The preview work well.
- Firefox with Java installation (no warning from OpenKM about not support for Scanner and Uploader): The preview work well.
- IE8 with no Java installation (with warning form OpenKM about not support for Scanner and Uploader): no Preview appear but the status told that "Starting conversion" and still there, nothing show.

I try to see setting of preview worked Chrome from MS Windows 7 to set into Chrome in Ubuntu 16.04.1 Desktop but the unlucky the Chrome in Ubuntu 16.04.1 Desktop still not show the preview.

So I quite confuse how to setup the Browser client to be able to work. It should not depends on Java plugin but what?

Thanks

SirFancyWeaselbocker
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Tue Jan 24, 2017 12:31 am

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by SirFancyWeaselbocker » Wed Feb 01, 2017 3:30 am

I performed the following steps and it corrected the preview problem in Firefox:

On my CentOS Server:
$ yum install zlib-devel libjpeg-devel giflib-devel freetype-devel gcc gcc-c++
$ wget http://www.swftools.org/swftools-0.9.2.tar.gz
$ tar xzf swftools-0.9.2.tar.gz
$ cd swftools-0.9.2
$ ./configure --prefix=/usr/local
$ make
$ make install
$ reboot

Client:
Updated flash to latest version and tested from Adobe.

Chrome will never work correctly because the uploader applet is forbidden to run. Firefox does work with it though just fine and the above solved my Firefox preview problems.

I'm not a sophisticated user by any means, but I'm fully functional following the above.

prachueb
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed Feb 01, 2017 3:00 am

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by prachueb » Wed Feb 01, 2017 3:36 am

It's work well now. :D

Thanks to welcomeweb
In Administration / profiles i checked option in tab General "Acrobat plugin preview"

and Thanks to jllort
Application comes with several ways to preview documents, if you use browser preview ( embeded acrobat reader preview ) then your users must have acrobat support in the browsers. The default preview goes with macro media flash player preview ( you should also get it enabled in your computers to take it running ).

viewtopic.php?t=20754#p41284

jllort
Moderator
Moderator
Posts: 9380
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by jllort » Thu Feb 02, 2017 2:38 pm

Is as you explain , you can preview documents as PDF embeded ( browser PDF plugin support needed ) or with .SWF ( flexpaper flash ). In professional we are working with HTML5 player and in nearly release we will try to move it to community.

prachueb
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Wed Feb 01, 2017 3:00 am

Re: Baffling Preview Problem - Works in some browsers, not in others.

Post by prachueb » Thu Feb 02, 2017 2:59 pm

Thanks jllort

Feel great to know your future movement.

Thanks again.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest