problemas con el openkm

OpenKM has many interesting features, but requires some configuration process to show its full potential.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
juanda2012
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Wed Mar 05, 2014 12:40 pm

problemas con el openkm

Post by juanda2012 » Wed Mar 05, 2014 1:02 pm

Application error
Class: org.apache.jasper.JasperException
Message: javax.servlet.ServletException: java.lang.ExceptionInInitializerError
Date: Tue Mar 04 07:35:02 COT 2014


Alguien me puede ayudar con este error?

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: problemas con el openkm

Post by jllort » Sat Mar 08, 2014 9:54 am

Esto que te pasa, al intentar logearte. Necesitariamos ver el log.
1- Para la aplicacion
2- Limpia el directorio de log
3- arranca la aplicacion, logeate y envianos el log aqui para hecharle un vistazo

Puede ser que tengas el repositorio corrupto

plugas
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Mar 01, 2017 5:23 pm

Re: problemas con el openkm

Post by plugas » Wed Mar 01, 2017 5:33 pm

Yo tambien tengo el mismo error. :(

Adjunto copia de los archivos catalina y localhost del log. Los coloco en texto aqui

Gracias por su ayuda.
Attachments
catalina - copia.doc
(94.81 KiB) Downloaded 8 times
localhost - copia.doc
(25.49 KiB) Downloaded 7 times

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: problemas con el openkm

Post by jllort » Fri Mar 03, 2017 7:27 pm

If you take a look at the error:

Code: Select all

Caused by: org.apache.lucene.index.CorruptIndexException: document count mismatch: deleted docs count 0 vs segment doc count 65412 segment=_2dor
Your lucene search index is corrupted. To solve it must generate it again, go with this steps:
1- stop openkm
2- delete the folder $TOMCAT_HOME/repository/index
3- start openkm
4- go to administration / tools
5- click on rebuild indexes, "choose rebuild lucene index" ( wait until the process be completed, can take some minutes or hours depending how many files do you have and the hardware you have )

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests