Page 1 of 1

OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sat Dec 02, 2017 9:35 am
by beli
Hi,

I have installed openKM 6.3.4 community version and the functionnality of Optical Mark Recognition is absent. How can I configure it ?
I want to test the functionnalities shown in https://docs.openkm.com/kcenter/view/ok ... lates.html.

Thanks in advance.

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sat Dec 02, 2017 4:33 pm
by jllort
By mistake was removed in previous version due major upgrade release. We have added again in the source code, if you compile it you will got it available or wait until we release next 6.3.5 ( in this month ).

The code is here https://github.com/openkm/document-mana ... ee/6.3-DEV

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sat Dec 02, 2017 11:10 pm
by beli
I'm preparing a presentation about the OMR feature in OpenKM that is scheduled for the end of this week.
In the domo.online, we can not access the administration feature. So, I have to follow the second solution based on building github sources.
Can you please give me some technical guidelines to execute it.

Thanks again.

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sun Dec 03, 2017 11:25 am
by jllort
1- First you should get installed version 6.3.4
2- The install git ( https://git-scm.com/downloads )
3- Checkout the project

Code: Select all

git checkout git@github.com:openkm/document-management-system.git
4- Install maven ( http://maven.apache.org/download.cgi and http://maven.apache.org/install.html )
5- Into the openkm project folder ( document-management-system ) execute ( note it can take some minutes because at the begining will start downloading all dependences ):

Code: Select all

mvn -Dmaven.test.skip=true clean package 
Another option is contact with sales & marketing and they might share with you an online cloud demo ( https://www.openkm.com/en/contact.html ), but this will be for professional version not for community one.

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Mon Dec 11, 2017 4:26 am
by beli
Hi,

After getting the source code in the jboss , I have this error in the pom.xml :

"Failure to transfer org.codehaus.mojo:gwt-maven-plugin:pom:2.4.0 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until
the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.codehaus.mojo:gwt-maven-plugin:pom:2.4.0 from/to central (http://
repo.maven.apache.org/maven2): null to http://repo.maven.apache.org/maven2/org ... -2.4.0.pom"

How can I fix it?.

Thinks.

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Thu Dec 14, 2017 12:07 pm
by beli
Hi,

I have followed all the steps

-Install code source from git and building a new war.
but the OMR functionality is not available.
Is there any configuration that I must do?
Thanks for your reply

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sat Dec 16, 2017 11:06 am
by jllort
Are you building the 6.3-DEV branch ? I have checked and all seems right. I attach an screenshot
support_164.png

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Fri Dec 22, 2017 4:56 am
by beli
Hi,

I have this problem: when I create a template the metadata list is empty?

Thanks

Re: OpenKM community 6.3.4 OMR - Optical Mark Recognition Not Found

Posted: Sat Dec 23, 2017 10:44 am
by jllort
Consider reading all documentation entries about Metadata https://docs.openkm.com/kcenter/view/ok ... adata.html ( this link and below )