Conversion to pdf ok but preview not working on MS Office files

Nous essayons de faire OpenKM aussi intuitif que possible, mais tout avis est bienvenu.

Moderator: dedisoft

Forum rules
Avant de poser une question, merci de regarder la documentation du wiki ou d'utiliser la fonction recherche du forum. Et rappelez vous que nous n'avons ni boule de cristal ni possibilité de lire dans les pensées, aussi pensez à spécifier quelle version d'OpenKM vous utilisez ainsi que la version du navigateur web et du système d'exploitation. Pour de plus amples informations lisez Comment reporter un bug efficacement (anglais).
Post Reply
Petr_Valenta
Senior Boarder
Senior Boarder
Posts: 45
Joined: Mon Mar 06, 2017 9:10 am

Conversion to pdf ok but preview not working on MS Office files

Post by Petr_Valenta » Wed Aug 09, 2017 11:57 am

Hello

I have a trouble with Preview on LibreOffice / MS Office files. I am able manually by means of menu to convert them into PDF. PDF file is created with no problem and is readable. And on these PDF-files preview works with no problem.

But when I try to display preview tab on the original office document (tried DOCX,XLSX,ODF), nothing is displayed. No message - nothing.

Configuration seems to be ok:
system.swftools.pdf2swf ---> OK - /home/openkm/tomcat-7.0.61/bin/pdf2swf
system.imagemagick.convert ---> OK - /usr/bin/convert
system.ocr ---> Not configured
system.openoffice.path ---> OK - /usr/lib64/libreoffice/program/soffice.bin

There is no error or exception in the log.

The only "suspicious" thing is incrementing number of messages
... frontend.GeneralServlet - getConversionStatus: ....frontend.client.bean.GWTConverterStatus@...
... frontend.GeneralServlet - getConversionStatus()

Any clue what can be wrong?

Server:
VMWare 12 Pro
Memory 12 GB
1 proc - 4 cores
Centos 7 Server
PostgreSQL 9.2.18
OpenKM 6.3.4

Many thanks in advance for your answer.

Petr Valenta
Last edited by Petr_Valenta on Sun Aug 13, 2017 3:51 pm, edited 2 times in total.

jllort
Moderator
Moderator
Posts: 9593
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Conversion to pdf ok but preview not working on MS Office files

Post by jllort » Sat Aug 12, 2017 8:09 am

I need to see the error in the catalina.log file while you are trying to preview the document.
Also check in your system, if after starting OpenKM you have a process named soffice running.
In what OS linux distribution did you have installed OpenKM ? if you are on CentOS, Redhat or Fedora, check it https://docs.openkm.com/kcenter/view/ok ... tml#CentOS

Petr_Valenta
Senior Boarder
Senior Boarder
Posts: 45
Joined: Mon Mar 06, 2017 9:10 am

Re: Conversion to pdf ok but preview not working on MS Office files

Post by Petr_Valenta » Sun Aug 13, 2017 3:49 pm

I can just repeat what I have already written here:
1. There is no error message anywhere. Catalina.out and OpenKM.log are without errors
2. I am on Centos 7
3. LibreOffice is installed and working - I am able to create PDF from DOCX with no problem even in OpenKM GUI.

And I have used your installer to install OpenKM.

Answers to your questions according to the link provided by you:

Code: Select all

yum install libreoffice
>>> Package 1:libreoffice-5.0.6.2-5.el7_3.1.x86_64 already installed and latest version
>>> Nothing to do

Code: Select all

yum install libreoffice-langpack-en
>>> Package 1:libreoffice-langpack-en-5.0.6.2-5.el7_3.1.x86_64 already installed and latest version
>>> Nothing to do

Code: Select all

rpm -qa | grep openoffice
>>> Nothing found
BUT

Code: Select all

rpm -qa | grep office
>>> libreoffice-base-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-opensymbol-fonts-5.0.6.2-5.el7_3.1.noarch
>>> libreoffice-draw-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-calc-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-math-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-impress-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-graphicfilter-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-pdfimport-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-writer-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-core-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-emailmerge-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-pyuno-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-ure-5.0.6.2-5.el7_3.1.x86_64
>>> libreoffice-langpack-en-5.0.6.2-5.el7_3.1.x86_64
Why are you asking me about installation of libreoffice and then suddenly openoffice?

Configuration from OpenKM GUI

Code: Select all

>>> system.openoffice.path	String	/usr/lib64/libreoffice
>>> Here is a difference - your pages are talking about /usr/bin/libreoffice
Configuration check

Code: Select all

>>> system.openoffice.path
>>> OK - /usr/lib64/libreoffice/program/soffice.bin

Code: Select all

ps -ef | grep -i soffice
openkm     3753   1125  0 17:07 ?        00:00:00 /usr/lib64/libreoffice/program/soffice.bin -accept=socket,host=127.0.0.1,port=2002;urp; -env:UserInstallation=file:///home/openkm/tomcat-7.0.61/temp/.jodconverter_socket_host-127.0.0.1_port-2002 -headless -nocrashreport -nodefault -nofirststartwizard -nolockcheck -nologo -norestore
Download as PDF

Code: Select all

>>> No problem, PDF made and readable

Code: Select all

Catalina.out
ug 13, 2017 5:20:29 PM org.artofsolving.jodconverter.office.ProcessPoolOfficeManager <init>
INFO: ProcessManager implementation is SigarProcessManager
Aug 13, 2017 5:20:29 PM org.artofsolving.jodconverter.office.OfficeProcess start
INFO: starting process with acceptString 'socket,host=127.0.0.1,port=2002,tcpNoDelay=1' and profileDir '/home/openkm/tomcat-7.0.61/temp/.jodconverter_socket_host-127.0.0.1_port-2002'
Aug 13, 2017 5:20:29 PM org.artofsolving.jodconverter.office.OfficeProcess start
INFO: started process; pid = 5117
OpenKM.log

Code: Select all

DocConverter - *** Build Office Manager ***
DocConverter - system.openoffice.path=/usr/lib64/libreoffice
DocConverter - system.openoffice.tasks=200
DocConverter - system.openoffice.port=2002
2017-08-13 17:20:29,806 [OfficeProcessThread-0] [] WARN  o.a.j.office.ManagedOfficeProcess - office process died with exit code 81; restarting it
So there is no error or exception here.

But I have just found Preview not working. Canot be there any connection to it?

jllort
Moderator
Moderator
Posts: 9593
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Conversion to pdf ok but preview not working on MS Office files

Post by jllort » Sun Aug 13, 2017 9:11 pm

Libreoffice is a fork of openoffice you can use both, but I do not know what you have installed, that why I talk about libreoffice or openoffice.
After OpenKM is started do you have soffice running ? seems from the output of the command line execution of ps, you got it running, then there's no problem with soffice service ( if you are able to convert a .doc to .pdf then it means the soffice service is going right ).
Might be is a problem with the browser what should support flash, otherwise the preview feature will not going right in community edition.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest