Page 1 of 1

Building error in development environment

Posted: Wed Nov 21, 2018 2:47 pm
by w12315007
Hi,
I downloaded the portable development environment( ova ), and imported it into virtualbox. I could start linux and
open the eclipse. But as starting the tomcat eclipse console shows errors : "Name [openkmDS] is not bound in this context.Unable to find [openkmDS]" (details in the attachment). At the same time, I can open the login
page in the browser(http://localhost:8080), but could not login the system after inputting the user name and password.
I am a java newer, so can anyone help me for this question? Thanks in advance.

Re: Building error in development environment

Posted: Thu Nov 22, 2018 8:30 am
by jllort
From where did you get the tomcat-8.5.24 ?
Check into server.xml if you have the entry Resource name="jdbc/OpenKMDS" uncomment ?
Depending on how you configure server from eclipse, it creates it's own server.xml when you execute from there, you should use the option I have marked in the screenshot.
support_521.png

Re: Building error in development environment

Posted: Fri Nov 23, 2018 9:37 am
by w12315007
Thanks for your reply.
the tomcat-8.5 is in the eclipse and I didn't do any change in tomcat or portable development environment (the ova doowload from openkm website) . I just add the openkm into the tomcat and debug. I checked the two points your mentioned and you can see reuslt in the attachment. It seems that these configures are right, do you have any other idears about this quesition? Thank you very much.

Re: Building error in development environment

Posted: Sat Nov 24, 2018 10:01 am
by jllort
Consider review your code ( might be you have changed something ? ), but seems is looking for "openkmDS" and in server.xml there's "OpenkmDS" with O in uppercase.