Authentication Error on First Attempt to Login

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
Wraith
Fresh Boarder
Fresh Boarder
Posts: 16
Joined: Fri Apr 03, 2015 1:45 pm

Authentication Error on First Attempt to Login

Post by Wraith » Sat Aug 04, 2018 8:24 am

Hi All,

I've recently "successfully" installed OpenKM and MySQL 8.0. Upon my first login attempt I am receiving an Authentication error.

I have tried the following combinations:
  • User: 'openkm'; Password: #Password# This is as per the user setup in the installation script
    User: 'okmAdmin'; Password: #Password# This is as per the user login shown in the installation video
In MySQL Workbench I've confirmed that the user 'openkm' has been created and database 'okmdb' exists.

Would appreciate any feedback or guidance on how to get the login working.

I've attached a compressed copy of openkm.log and catalina.log

Thanks in advance
Attachments
logs.7z
(9.93 KiB) Downloaded 7 times
OS: Windows Server 2012 R2
OPENKM: v6.3.6 Community Edition
mySQL: v8.0.12
Tomcat: v8.5.24
Python: v2.7.15 32-bit

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Authentication Error on First Attempt to Login

Post by jllort » Sat Aug 04, 2018 3:35 pm

We need the catalina.log file for a detailed error stack trace ( stop OpenKM, delete all files into log folder, start again, try to login and share with us the file ).
Also I suggest read this documentation section https://docs.openkm.com/kcenter/view/ok ... oting.html

Wraith
Fresh Boarder
Fresh Boarder
Posts: 16
Joined: Fri Apr 03, 2015 1:45 pm

Re: Authentication Error on First Attempt to Login

Post by Wraith » Sun Aug 05, 2018 7:24 am

Hi jllort,

The catalina.log and openkm.log files were attached within the 7zip archive attached to the first post. I wasn't permitted to upload a .log file.

I have read the resource you've linked and made the changes suggested within. I also, based on other posts, have stoped OpenKM, modified the OpenKM.cfg file to read "...=create" on the appropriate line, deleted the repository file, restarted OpenKM and tried to access again.

In my opinion, some or all of the above contributed to me getting as far as I have [the login screen]. Let me know if you need any other info or the catalina.log file uploaded in a different format or manner.

Thanks for your help so far.
OS: Windows Server 2012 R2
OPENKM: v6.3.6 Community Edition
mySQL: v8.0.12
Tomcat: v8.5.24
Python: v2.7.15 32-bit

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Authentication Error on First Attempt to Login

Post by jllort » Sun Aug 05, 2018 11:26 am

I do not see any kind of error in the log ( only wrong authentication for okmAdmin user what is quite strange ). Also I was expected to find some extra rows what in your case seems are missing in the log for a complete OpenKM starting up, like soffice binding or server start up time in the log what is not shown in your case.

How are you starting the application ?
Check default tomcat ports be available an not used by other apps ? 8080, 8005 and 8009

Wraith
Fresh Boarder
Fresh Boarder
Posts: 16
Joined: Fri Apr 03, 2015 1:45 pm

Re: Authentication Error on First Attempt to Login

Post by Wraith » Wed Aug 08, 2018 1:36 pm

Hi jllort,
How are you starting the application ?
I find "OpenKM" in Services, right click and select Start
Check default tomcat ports be available an not used by other apps ? 8080, 8005 and 8009
netstat -n -a -o does not report any PID's using ports 8080, 8005 or 8009.

Thanks!
OS: Windows Server 2012 R2
OPENKM: v6.3.6 Community Edition
mySQL: v8.0.12
Tomcat: v8.5.24
Python: v2.7.15 32-bit

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Authentication Error on First Attempt to Login

Post by jllort » Fri Aug 10, 2018 5:58 am

The OS user and password are ( openkm / openkm )
The OpenKM default user and password are ( okmAdmin / admin ) -> do not forget to write the A ( Uppercase )

Wraith
Fresh Boarder
Fresh Boarder
Posts: 16
Joined: Fri Apr 03, 2015 1:45 pm

Re: Authentication Error on First Attempt to Login

Post by Wraith » Sun Aug 12, 2018 10:59 am

The OS user and password are ( openkm / openkm )
This didn't work :(
The OpenKM default user and password are ( okmAdmin / admin ) -> do not forget to write the A ( Uppercase )
This DID work! :)

Would appreciate some clarity - If the passwords are either "openkm" or "admin" then what is the password entered or chosen during the installation process?
OS: Windows Server 2012 R2
OPENKM: v6.3.6 Community Edition
mySQL: v8.0.12
Tomcat: v8.5.24
Python: v2.7.15 32-bit

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Authentication Error on First Attempt to Login

Post by jllort » Sun Aug 12, 2018 5:08 pm

The user openkm with password openkm is for OS of the Virtual Machine, the OpenKM development environment. In both cases, clean installation or running the development environment the credentials for the OpenKM application are user okmAdmin with password admin. Might be now the explanation is clearly ?

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests