Migration from CE 6.3.4 to 6.3.5

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
mi_685
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Sun Jun 24, 2018 9:48 am

Migration from CE 6.3.4 to 6.3.5

Post by mi_685 » Sun Jun 24, 2018 10:03 am

Hi folks,

i tried to migrate from my CE 6.3.4 to 6.3.5 following the guide "https://docs.openkm.com/kcenter/view/ok ... to-635.html".

After executing the script there are no result or error displayed. Seems to me i'm successful.
But in administration tab i still get the old version displayed "Version: 6.3.4 (build: 47204ef)"

What i'm doing wrong?

Thanks.

lnovoa
Expert Boarder
Expert Boarder
Posts: 101
Joined: Tue Mar 27, 2018 8:00 am

Re: Migration from CE 6.3.4 to 6.3.5

Post by lnovoa » Tue Jun 26, 2018 8:02 am

Hi!,

Have you stopped tomcat, deleted the detailed folders and cleaned the browser cache?
If you have any weird problem try to stop Tomcat, delete these folders:

$TOMCAT_HOME/webapps/OpenKM
$TOMCAT_HOME/work/Catalina/localhost
Recommended to clear browser cache and Java Plugin cache.

mi_685
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Sun Jun 24, 2018 9:48 am

Re: Migration from CE 6.3.4 to 6.3.5

Post by mi_685 » Tue Jun 26, 2018 6:01 pm

Thanks Inovoa. I followed your advice and delete both folders and clear caches.

Now after logging in as Admin (or any other user) i get the Error message below. Cant continue.
Image

If i restore both folders, everything works as before.

Any ideas?

mi_685
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Sun Jun 24, 2018 9:48 am

Re: Migration from CE 6.3.4 to 6.3.5

Post by mi_685 » Tue Jun 26, 2018 7:30 pm

Error solved by myself. Works fine know.

Solution: before restart tomcat, change the OpenKM.cfg again to "hibernate.hbm2ddl=update"

All together, for a sucessfull update here are my steps:

1. Make a backup!!!
2. Stop Tomcat
3. Edit OpenKM.cfg and set hibernate.hbm2ddl to update
4. Replace the OpenKM.war
5. Delete these folders:
- $TOMCAT_HOME/webapps/OpenKM
- $TOMCAT_HOME/work/Catalina/localhost
6. Start Tomcat again
7. Go to Administration > Scripting execute:

Code: Select all

import com.openkm.core.DatabaseException;
import com.openkm.dao.bean.CronTab;
import com.openkm.dao.CronTabDAO;

static final String MAIL = "noreply@openkm.com";

try {
    for (CronTab ct : CronTabDAO.findAll()) {
        if (ct.getMail().equals(MAIL)) {
            ct.setMail("");
            CronTabDAO.update(ct);
        }	
    }
} catch (Exception e) {
    print("Exception: " + e);
}
Thats all. :lol:

lnovoa
Expert Boarder
Expert Boarder
Posts: 101
Joined: Tue Mar 27, 2018 8:00 am

Re: Migration from CE 6.3.4 to 6.3.5

Post by lnovoa » Wed Jun 27, 2018 7:33 am

Perfect, I see that you have followed the manual correctly.

dferguson
Expert Boarder
Expert Boarder
Posts: 107
Joined: Thu May 18, 2017 12:48 pm

Re: Migration from CE 6.3.4 to 6.3.5

Post by dferguson » Tue Sep 25, 2018 5:53 pm

That is not really fair.

The manual only says to delete the /OpenKM/ and /localhost/ folders if stopping tomcat results in any weird issues. I too had no signs of tomcat stopping weird which would result in having delete those folders per the manual.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests