Implementation Versions of OpenKM community version 6.3.4

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
PSHREYASHOLLA
Senior Boarder
Senior Boarder
Posts: 47
Joined: Thu Dec 22, 2016 4:18 am

Implementation Versions of OpenKM community version 6.3.4

Post by PSHREYASHOLLA » Fri Mar 16, 2018 9:21 am

Hi,

I had installed OpenKM community version 6.3.4 sometime back and the OKMInstaller deployed OpenKm on tomcat-7.0.61. When I see the Installers MANIFEST.MF file it says Implementation-Version: 0.6.0-CE.

Now if I install OpenKM community version 6.3.4 using latest OKMInstaller.jar, it deploys openKM on tomcat-8.5.24. The version says app.version=0.9.5-CE.

Please let me know where can I get the older installables which used to deploy OpenKm on tomcat-7.0.61.?

jllort
Moderator
Moderator
Posts: 10243
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Implementation Versions of OpenKM community version 6.3.4

Post by jllort » Sat Mar 17, 2018 8:18 am

All releases are here https://github.com/openkm/document-mana ... m/releases, should not be a problem deploying into tomcat-7 or tomcat 8

PSHREYASHOLLA
Senior Boarder
Senior Boarder
Posts: 47
Joined: Thu Dec 22, 2016 4:18 am

Re: Implementation Versions of OpenKM community version 6.3.4

Post by PSHREYASHOLLA » Tue Mar 20, 2018 5:52 am

Hi Jllort,

As I mentioned the official OpenKM site download page has 6.3.4CE https://www.openkm.com/en/download.html.

When i had installed 6.3.4 sometime back its MANIFEST.MF read Version: 0.6.0-CE.

But now if I install 6.3.4 version reads app.version=0.9.5-CE.

And a functionality which was working in 6.3.4(0.6.0-CE) is not working in 6.3.4(0.9.5-CE).

So is there a way to get installabled of 6.3.4(0.6.0-CE).

pavila
Moderator
Moderator
Posts: 3050
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Implementation Versions of OpenKM community version 6.3.4

Post by pavila » Fri Mar 23, 2018 4:35 pm

Sorry, which MANIFEST.MF are you talking about?

PSHREYASHOLLA
Senior Boarder
Senior Boarder
Posts: 47
Joined: Thu Dec 22, 2016 4:18 am

Re: Implementation Versions of OpenKM community version 6.3.4

Post by PSHREYASHOLLA » Wed Mar 28, 2018 6:09 am

Hi,

The one which will be present in OKMInstaller.jar\META-INF\META-INF.MF.


The problem here is,

We had integrated with OpenKM 6.3.4CE. And we are using Java SDK 1.1 APIs.
We used to upload the document using,
com.openkm.sdk4j.OKMWebservices.createDocumentSimple(String docPath, InputStream is)

And then we are associating document properties by calling,
com.openkm.sdk4j.OKMWebservices.setPropertyGroupPropertiesSimple(String nodeId, String grpName, Map<String, String> properties)


But after consuming latest OpenKM 6.3.4CE from https://www.openkm.com/en/download.html,

API com.openkm.sdk4j.OKMWebservices.setPropertyGroupPropertiesSimple(String nodeId, String grpName, Map<String, String> properties)
is failing with error group is not associated with the node.

Its expecting first to call,
com.openkm.sdk4j.OKMWebservices.addGroup(String nodeId, String grpName) and then to call,
com.openkm.sdk4j.OKMWebservices.setPropertyGroupPropertiesSimple(String nodeId, String grpName, Map<String, String> properties)


This is causing problems as we will not be able to certify on a Particular version OpenKM 6.3.4CE, because of the Functionality change.

SO looking forward for the solution :cry:

pavila
Moderator
Moderator
Posts: 3050
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Implementation Versions of OpenKM community version 6.3.4

Post by pavila » Wed Mar 28, 2018 6:39 am

Sorry, but I don't understand the relation between the OKMInstaller manifest and the SDK & property groups issue.

PSHREYASHOLLA
Senior Boarder
Senior Boarder
Posts: 47
Joined: Thu Dec 22, 2016 4:18 am

Re: Implementation Versions of OpenKM community version 6.3.4

Post by PSHREYASHOLLA » Wed Mar 28, 2018 8:44 am

Hi,

Let me reiterate the issue.

We had installed OpenKM 6.3.4 Community Edition from the openKM official website sometime back. Please find the attached Installer jar, named OKMInstaller_Old.jar.

We are using Java SDK 1.1 APIs.
We used to upload the document using,
com.openkm.sdk4j.OKMWebservices.createDocumentSimple(String docPath, InputStream is)

And then we are associating document properties by calling,
com.openkm.sdk4j.OKMWebservices.setPropertyGroupPropertiesSimple(String nodeId, String grpName, Map<String, String> properties).

The above functionality was working fine and we had certified our Application with OpenKM 6.3.4 Community Edition.


But today when I try to install OpenKM 6.3.4 Community Edition from the openKM official website, I get the Installer jar, named OKMInstaller_New.jar.
And we are installing OpenKm using the same.

But now the behaviour is different i.e
com.openkm.sdk4j.OKMWebservices.createDocumentSimple(String docPath, InputStream is)
Is working fine but,

com.openkm.sdk4j.OKMWebservices.setPropertyGroupPropertiesSimple(String nodeId, String grpName, Map<String, String> properties)

Is failing with the error,

com.openkm.rest.GenericException: com.openkm.core.RepositoryException: Property group not assigned to this node



Please let me know if u need more details. :)

pavila
Moderator
Moderator
Posts: 3050
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Implementation Versions of OpenKM community version 6.3.4

Post by pavila » Wed Mar 28, 2018 11:51 am

The latest OpenKM CE version is 6.3.6 and if the installer got another versoin, then there is an issue related to the installer. Please, verify the installer version is 0.9.5-CE (build: 7363361)

PSHREYASHOLLA
Senior Boarder
Senior Boarder
Posts: 47
Joined: Thu Dec 22, 2016 4:18 am

Re: Implementation Versions of OpenKM community version 6.3.4

Post by PSHREYASHOLLA » Thu Mar 29, 2018 5:45 am

Hi,

As I mentioned earlier,
Installer version says app.version=0.9.5-CE.

https://www.openkm.com/en/download.html


But the installation official page shows 6.3.4CE :?:

pavila
Moderator
Moderator
Posts: 3050
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: Implementation Versions of OpenKM community version 6.3.4

Post by pavila » Thu Mar 29, 2018 9:05 am

The download page points to an old version, it's true. But the link to the installer is fine. Using the installer is the recommended way to install OpenKM. When I said "0.9.5-CE" I was talking about the OKMInstaller version, not the OpenKM version.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests