jar file installation failed on centos at the beginning

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
saman_s1
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Thu Nov 16, 2017 2:05 pm

jar file installation failed on centos at the beginning

Post by saman_s1 » Thu Nov 16, 2017 2:12 pm

hi,
After instal jdk 8, I'm trying to install from jar file, but it show this error at the beginning:
Running in Linux: 0.0.0 (build: 0)
Linux distro: centos (CentOS - 6.9)
ERROR: Unable to get local address
I google it but not found any similar problem, could you please help on this ?
thanks.

jllort
Moderator
Moderator
Posts: 10077
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: jar file installation failed on centos at the beginning

Post by jllort » Sat Nov 18, 2017 10:35 am

I suspect might be wrong or incomplete network configuration. Try to ping server name, I think is not able to resolve its own server name.

saman_s1
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Thu Nov 16, 2017 2:05 pm

Re: jar file installation failed on centos at the beginning

Post by saman_s1 » Mon Dec 04, 2017 12:09 pm

thanks for your reply,
it is reply ping request on server name.
it just can't connect to java/oracle site, is it required option ?

jllort
Moderator
Moderator
Posts: 10077
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: jar file installation failed on centos at the beginning

Post by jllort » Tue Dec 05, 2017 6:23 pm

The installer will download resources from sourceforge , at least while installing the application should have internet access.

zio_tom78
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Thu Oct 25, 2012 8:12 am

Re: jar file installation failed on centos at the beginning

Post by zio_tom78 » Thu Jan 04, 2018 9:27 am

After instal jdk 8, I'm trying to install from jar file, but it show this error at the beginning
I am getting the very same error using the same CentOS release (6.9, on a i686 machine). What's funny is that this problem does not appear when using CentOS 7.0 64-bit.

(Background: I created a virtual machine and installed CentOS 7, then I installed OpenKM 6.3 CE on it. Later, I realized I had to move this VM on a 32-bit computer, so I created a new VM and installed CentOS 6.9, which still supports 32-bit architectures, and got struck because of the same problem.)

The network seems to be set up correctly, however. Here is the network configuration:

Code: Select all

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:4d:c9:e4 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
    inet6 fe80::a00:27ff:fe4d:c9e4/64 scope link
       valid_lft forever preferred_lft forever
Here is the result of pinging localhost:

Code: Select all

# ping -c 3 localhost 
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.023 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.044 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.026 ms

--- localhost ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.023/0.031/0.044/0.009 ms
And finally, this should prove that DNS setup is correct:

Code: Select all

# ping www.google.com
PING www.google.com (216.58.205.132) 56(84) bytes of data.
64 bytes from mil04s27-in-f4.1e100.net (216.58.205.132): icmp_seq=1 ttl=52 time=3.48 ms
64 bytes from mil04s27-in-f4.1e100.net (216.58.205.132): icmp_seq=2 ttl=52 time=1.87 ms
64 bytes from mil04s27-in-f4.1e100.net (216.58.205.132): icmp_seq=3 ttl=52 time=2.81 ms

--- www.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2006ms
rtt min/avg/max/mdev = 1.872/2.721/3.482/0.663 ms
Running

Code: Select all

yum update
followed by

Code: Select all

yum upgrade
do not seem to help. Currently I am short of ideas about how to make the installer work.

Maurizio.

jllort
Moderator
Moderator
Posts: 10077
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: jar file installation failed on centos at the beginning

Post by jllort » Fri Jan 05, 2018 12:20 pm

I do not suggest install OpenKM in a 32 bits OS I suggest discard this scenario, 32 bits architecture is totally obsolete and you will have a lot of problems with memory and JAVA. Confirm to me if the issues is with Centos 6.9 32 bits or also with 64 bits

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest