front-end unresponsive after few minutes

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
eurbinati
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Fri Sep 04, 2015 10:20 am

front-end unresponsive after few minutes

Post by eurbinati » Fri Mar 10, 2017 5:13 pm

I have installed OpenKM 6.3.1 on a Windows Server 2012 R2 virtual box.
Everything seemed working properly, so I have uploaded 40'000 pdf files as administrator via web services (using 2 levels taxonomy, categories, keywords and metadata).
Now, opening the OpenKM front-end everything seems working properly for just few minutes, after that I get a browser error message saying the page has become unresponsive.
Please find attached Chrome and FireFox error message.
Thanks for your support
Attachments
ErrPageUnresponsiveFF.png
ErrPageUnresponsive.png

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: front-end unresponsive after few minutes

Post by jllort » Sat Mar 11, 2017 9:55 am

In a 99% percent I think the problem is the keywrods. How many keywords do you have ? go to administration / database query and execute

Code: Select all

select COUNT(DISTINCT(NKW_KEYWORD)) from OKM_NODE_KEYWORD
We do not suggest using keywords ( only in cases you are a company of 5 users or less, and you will create with keywords, a tag cloud of thousands of keywords is something totally useless you will not find anything from there. Always we suggest enclosed list and metadata groups. Really what you can do with keywords can be done by categories and what can be done with categories can be done with metadata groups. But not reverse, that means what can be done with metadata groups can not be done with categories etc..

Confirm to me this point. The problem is rendering a huge tag cloud. From dashboard you have a draw of the complete tag cloud, that means thousands of keywords are loaded into the browser ( js call ) and then saves into a list while at the same time is rendering a tag cloud of thousands of elements ( that's what happening by default if you have tag cloud enabled from dashboard view ). From here you can thinking, how useful is a tag cloud of thousand of keywords ? almost times not value is noise.

Finally if for example you are uploading 40K invoices and you are taggind document with invoice number, then you having a bad use of keyword, the correct should be create a metadata group with a single field ( invoice number ) and set there this value. Take a look at:
https://docs.openkm.com/kcenter/view/ok ... adata.html
https://docs.openkm.com/kcenter/view/ok ... field.html
https://docs.openkm.com/kcenter/view/ok ... earch.html

Finally here you have some suggestions about how plan your DMS
https://docs.openkm.com/kcenter/view/ok ... ntals.html
https://docs.openkm.com/kcenter/view/ok ... ation.html

eurbinati
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Fri Sep 04, 2015 10:20 am

Re: front-end unresponsive after few minutes

Post by eurbinati » Sat Mar 11, 2017 11:30 am

Thank you very much for your quick feedback.

select COUNT(DISTINCT(NKW_KEYWORD)) from OKM_NODE_KEYWORD
52268

At the moment we are using just one user, we develop a CRM - OKM integration, so the 4 CRM users we have, are mainly using the CRM interface.

The saved documents are mainly activity reports uploaded when the related Service Requests have been solved. We have all the metadata we need in CRM database and we would like to save them into OKM in order to easily find those documents in OKM.

We have used Taxonomy, Category (because the same document could have several metadata of the same type), Metadada and keywords to classify each document. We decided to add keywords because of easier to use search functionalities (it seems much easier to find a document if it has keywords).
Basically we found easy to use the "find document" button, but the search is limited to the filename.
Fulltext search is quite accessible as well, but it seems not looking in metadata neither in categories.
Advanced search is a little bit less user friendly, but it has keywords in the Basic tab, so it is not too bad.
Looking for documents using Categories or Metadata is seems not user friendly at all to us.

How do you suggest to go ahead?
I guess removing keywords via web services :-(
Does it make sense to add keywords into filename?
Is there a limit in the filename length?
Of course we could add keywords to metadata, but as said we have 1:N relationship to handle (e.g. the same document could be linked to more than 1 service request) and even worst, the search by metadata is not appreciated by our end users.
Is there a way to use effectively "Fulltext search" in our case?

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: front-end unresponsive after few minutes

Post by jllort » Sat Mar 11, 2017 5:45 pm

You must change keywords to metadata, can do by webservices or with an script.
About categories you can use select field, where you can have serveral values at the same time, take a look here https://docs.openkm.com/kcenter/view/ok ... plechoises

I suggest a metadata group with two filds 1 input for the keyword you are using now and 1 select for multiple values.

What language are you using between your crm and OpenKM ?

eurbinati
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Fri Sep 04, 2015 10:20 am

Re: font-end unresponsive after few minutes

Post by eurbinati » Sat Mar 11, 2017 6:13 pm

We are using php.

I still have to read carefully all the useful info you gave me.
Anyway using metadata instead of keywords I guess we will solve the front-end unresponsive issue, but we will introduce the search functionality one.

Our users really do not like the search by metadata functionality offered by OpenKM :-(.
Is there an easier way to let users search documents by metadata?

Again, thank you very much for your valuable support

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: front-end unresponsive after few minutes

Post by jllort » Sun Mar 12, 2017 7:01 pm

First of all you should be interested in using our PHP sdk https://docs.openkm.com/kcenter/view/sdk4php-1.1.1/ ( I do not know if you are using it )

I think your users might be interested in a simplified UI, you can create your own look & feel only for searching with php, follow this link https://docs.openkm.com/kcenter/view/sd ... dPaginated

A real example of it, if our documentation site at https://docs.openkm.com what really is based in KCenter https://www.openkm.com/en/build-your-own-app.html . The idea is have OpenKM and across SDK in the middle build your own user interface. Really SDK is a wrapper of our OpenKM API https://docs.openkm.com/kcenter/view/ok ... ption.html ( community version is not so much complete as professional but I for what you are explaining is enought ).

eurbinati
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Fri Sep 04, 2015 10:20 am

Re: front-end unresponsive after few minutes

Post by eurbinati » Sun Mar 12, 2017 11:56 pm

I have deleted almost all the keywords and now
SELECT COUNT(DISTINCT(NKW_KEYWORD)) FROM OKM_NODE_KEYWORD
returns 5.
I do not find the documents using the 5 keywords left, anyway the front-end seems to work properly again, so we are happy :-)

We are not using OpenKM php SDK, and considering the interface seems working pretty well, I do not think we'll start using it now.

I think, as a first step, we'll add some keywords to the filenames and use the OpenKM top left search button, then probably as you suggested we'll develop a simplified UI to search documents.

Thank you very much for your time, suggestions and support.

BTW: I've just realised the error in post title: "font-end" instead of "front-end", so I'm sorry, probably this post would be better reachable fixing it, but I do not think to have the right to do it.

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: front-end unresponsive after few minutes

Post by jllort » Tue Mar 14, 2017 7:40 pm

I have corrected the title

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest