Fresh Installaction CentOS 6 64-bit - Can't Open

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Sat Oct 15, 2016 8:41 pm

Fresh Installaction CentOS 6 64-bit - Can't Open

Post by dedwards » Sat Oct 15, 2016 9:02 pm

Hello everyone,

I've been looking for an OpenSource DMS to implement into a small IT Business to centralize all documentation. After several research I found myself with OpenKM Community Version.

I always like to try installing stuff on DigitalOcean Personal Droplets, as a mean of testing things from outside a local network. I'm currently trying to install the "Quick Install" OpenKM 6.3. So far I have the following (CentOS Droplet, no GUI, DNS and Domain set up):

SELinux - Disabled
IPTables - Disabled

Downloaded .run file on /tmp/
Downloaded Java JDK 8.rpm from Oracle, installed in /usr/java/
Set up SymLink for /usr/bin/java

Tested java -version:

Code: Select all

java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Wizard installed properly on /opt/ (with error creating menu shortcut).
Modified JAVA_HOME to point to /usr/java/jdk*

When I try /tomcat/bin/ I get:

Code: Select all

Using CATALINA_BASE:   /opt/openkm-6.3.2-community/tomcat
Using CATALINA_HOME:   /opt/openkm-6.3.2-community/tomcat
Using CATALINA_TMPDIR: /opt/openkm-6.3.2-community/tomcat/temp
Using JRE_HOME:        /usr/java/jdk1.8.0_101
Using CLASSPATH:       /opt/openkm-6.3.2-community/tomcat/bin/bootstrap.jar:/opt/openkm-6.3.2-community/tomcat/bin/tomcat-juli.jar
Using CATALINA_PID:    /opt/openkm-6.3.2-community/tomcat/
Existing PID file found during start.
Removing/clearing stale PID file.
Tomcat started.

I try opening http://serverip:8080/OpenKM but I get connection refused. Tried, connection refused. From within the server I tried:
curl http://localhost:8080/OpenKM

Code: Select all

curl: (7) couldn't connect to host
ps -ef |grep java

Code: Select all

root     26427 25587  0 20:50 pts/0    00:00:00 grep java

Catalina Log:

Code: Select all

Oct 15, 2016 8:48:29 PM org.apache.catalina.startup.Catalina load
WARNING: Catalina.start using conf/server.xml: Error at (36, 111) : com.openkm.util.Log4JInitializer
Oct 15, 2016 8:48:29 PM org.apache.tomcat.util.digester.Digester startElement
SEVERE: Begin event threw exception
java.lang.ClassNotFoundException: com.openkm.util.Log4JInitializer
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
Seems like java isn't even running.

Any suggestions?

Posts: 9644
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain

Re: Fresh Installaction CentOS 6 64-bit - Can't Open

Post by jllort » Sun Oct 16, 2016 6:31 pm

Ensure the tomcat/bin/ is not pointing to another JDK
( I suggest JDK 1.7 might be a problem with this tomcat version and JDK 1.8 )

If does not going right :
1- stop openkm
2- clean logs folder
3- start openkm from command line with -> ./bin/ run
4- wait until the tomcat be started up
5- upload here the catalina.log file into zip file and we will take a look into about what's happening

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests