ERROR: OpenKM needs Java 1.7 or 1.8

Problems with installing OpenKM? No problemo, the solution is closer than you think.
Forum rules
Please, before asking something see the documentation wiki or use the search feature of the forum. And remember we don't have a crystal ball or mental readers, so if you post about an issue tell us which OpenKM are you using and also the browser and operating system version. For more info read How to Report Bugs Effectively.
Post Reply
jnmwarren
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Tue Feb 13, 2018 1:46 am

ERROR: OpenKM needs Java 1.7 or 1.8

Post by jnmwarren » Tue Feb 13, 2018 1:53 am

I am trying to install OpenKM. When I click on the file OKMInstaller.jar. I get the following error log. I have Java 8.161 installed as well as Java Development kit 9.0.4. How do I get the software installed and working? Thanks, John

2018-02-12 18:35:17,604 [ main] INFO com.openkm.installer.Main - Running in Windows: 0.9.3-CE (build: 32e830e)
2018-02-12 18:35:17,616 [ main] INFO com.openkm.installer.Main - Local host: DESKTOP-VNDRI0R (192.168.1.9)
2018-02-12 18:35:17,617 [ main] INFO com.openkm.installer.Main - Java version: 9.0.4
2018-02-12 18:35:17,618 [ main] INFO com.openkm.installer.Main - JAVA_HOME = C:\openkm-dev\tools\EclipsePortable\App\Java\jdk1.7.0_75
2018-02-12 18:35:17,642 [ main] INFO com.openkm.installer.Main - Free disk size: 738.6 GB
2018-02-12 18:35:17,671 [ main] INFO com.openkm.installer.Main - RAM size: 15.9 GB
2018-02-12 18:35:17,671 [ main] INFO com.openkm.installer.Main - CPU cores: 8
2018-02-12 18:35:17,672 [ main] INFO com.openkm.installer.Main - Current directory: D:\@Data\Downloads
2018-02-12 18:35:17,673 [ main] INFO com.openkm.installer.Main - ERROR: OpenKM needs Java 1.7 or 1.8
2018-02-12 18:35:17,674 [ main] ERROR com.openkm.installer.Main - OpenKM needs Java 1.7 or 1.8
java.lang.Exception: OpenKM needs Java 1.7 or 1.8
at com.openkm.installer.Main.a(SourceFile:188)
at com.openkm.installer.Main.main(SourceFile:87)

jnmwarren
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Tue Feb 13, 2018 1:46 am

Re: ERROR: OpenKM needs Java 1.7 or 1.8

Post by jnmwarren » Tue Feb 13, 2018 12:31 pm

I have solved the Java error. I am now trying to start the Tomcat Apache server. However it is not listed in the Services part of Windows. How do I get it to show up so that I can start it?

Thanks,
John

jllort
Moderator
Moderator
Posts: 9794
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: ERROR: OpenKM needs Java 1.7 or 1.8

Post by jllort » Thu Feb 15, 2018 5:56 pm

About the question, you should use JDK 1.8 ( 64 bits architecture )
Here are explained how to configure windows service ( might be the only difference from the screenshots will be the paths and if you do not find a file named tomcat7w.exe is becaused has renamed to openkmw.exe, but these might be the only differences from your scenario )
https://docs.openkm.com/kcenter/view/ok ... asaservice

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest