Busqueda en OpenKM 6.3.6 no funciona

Hemos intentado hacer de OpenKM una aplicación lo más intuitiva posible, sin embargo siempre viene bien algún consejo.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
inava
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Jan 16, 2019 10:12 pm

Busqueda en OpenKM 6.3.6 no funciona

Post by inava » Wed Jan 16, 2019 10:59 pm

Buen día a todos.
He instalado OpenKM 6.3.6 build 87d181f (community edition)
Apache Tomcat 8.5.24
MySQL 5.7.24

He subido distintos archivos PDF, TIF, JPG y TXT; he intentado utilizar la búsqueda, pero no me funciona; ya hemos intentado por texto libre, por todos los campos de la búsqueda avanzada y nada; no me despliega ningún resultado.
Me está faltando activar algún parámetro? Alguna configuración?
Gracias desde ya por sus comentarios.

lnovoa
Expert Boarder
Expert Boarder
Posts: 119
Joined: Tue Mar 27, 2018 8:00 am

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by lnovoa » Fri Jan 18, 2019 3:49 pm

Hola,
antes de nada preguntarte si el usuario con el que haces las búsquedas es el okmAdmin o no.

Si accedes como administrador debes de encontrarlo todo pero en el caso de ser un usuario normal tendrías que comprobar
que tienes permisos sobre esos documentos.

Por otro lado, si estas como administrador y has subido documentos que no se muestran en la búsqueda, puedes ir a Administration->rebuild indexes y reindexar por indices y por lucene.
Una vez que haya terminado refresca el escritorio y vuelve a buscar.

inava
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Jan 16, 2019 10:12 pm

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by inava » Sat Jan 19, 2019 7:33 pm

Inovoa muchas gracias por tu respuesta.
Respondiendo a las preguntas:
Si, todas las actividades descritas en el post son con el usuario okmAdmin.
De igual manera reconstruí indices, utilice las opciones incluyendo lucene, reinicie completamente los servicios sin ningún resultado, no he logrado hacer funcionar ni por búsqueda normal mucho menos la avanzada.

lnovoa
Expert Boarder
Expert Boarder
Posts: 119
Joined: Tue Mar 27, 2018 8:00 am

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by lnovoa » Mon Jan 21, 2019 9:08 am

Hola,
es un raro lo que comentas porque si realizas bien las búsquedas no debe de dar problemas.
Revisa la configuración con lucene a ver si esto te ayuda:
https://docs.openkm.com/kcenter/view/ok ... lyzer.html

jllort
Moderator
Moderator
Posts: 10660
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by jllort » Tue Jan 22, 2019 6:39 pm

podriamos empezar por aislar un caso concreto
1- realiza una captura de pantalla de la consulta ( con usuario administrador ROLE_ADMIN )
2- realiza una captura de pantalla del documento ( donde podamos ver los valores por los que estas buscando, sea el contenido, el nombre etc.. )

a partir de aquí vamos a ir avanzando

inava
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Jan 16, 2019 10:12 pm

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by inava » Thu Jan 24, 2019 3:40 pm

Buen dia.
Inovoa, jllort
gracias por los comentarios.
Finalmente decidí hacer una instalación nueva de OpenKM, todo desde cero y está funcionando casi al 100%. Las búsquedas avanzadas funcionan perfecto por cualquier parámetro, no así la búsqueda por texto libre; pero creo que se puede prescindir de ella para trabajar la plataforma.
La causa del problema en la primer instalación tal vez pudo ser que inicialmente instalé MySQL 8 en lugar de la versión recomendada, de igual manera actualicé Tomcat y reconfiguré algunas variables de entorno. Suposiciones todas.
De nuevo gracias y espero la experiencia sea útil para la comunidad.
Un saludo desde México.

jllort
Moderator
Moderator
Posts: 10660
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by jllort » Sat Jan 26, 2019 10:12 am

Estamos hablando de búsquedas por contenido, verdad ?
Unos conceptos previos, los documentos cuando suben a OpenKM, se ponen en una cola de indexación para procesar el contenido ( extraer el texto ) y indexarlo, mientras el documento esta en la cola obviamente no vas a poder buscar por contenido. Puedes ver la cola desde Administracion > Stats > Pending text extraction queue ( menu superior derecho )

- lo primero es subir un fichero de TXT y confirmar que despues de que ha sido procesado en la cola de indexación puedes localizarlo por el contenido.

Cuando este paso este funcionando, podremos hablar de ficheros PDF y otros formatos.

inava
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Jan 16, 2019 10:12 pm

Re: Busqueda en OpenKM 6.3.6 no funciona

Post by inava » Tue Jan 29, 2019 3:42 pm

Buen dia.
jilort nuevamente gracias por el comentario.
Recién inicio con la operación y conocimiento del OpenKM y es de mucha utilidad conocer estos detalles de la operación.
Saludos.
jllort wrote:
Sat Jan 26, 2019 10:12 am
Estamos hablando de búsquedas por contenido, verdad ?
Unos conceptos previos, los documentos cuando suben a OpenKM, se ponen en una cola de indexación para procesar el contenido ( extraer el texto ) y indexarlo, mientras el documento esta en la cola obviamente no vas a poder buscar por contenido. Puedes ver la cola desde Administracion > Stats > Pending text extraction queue ( menu superior derecho )

- lo primero es subir un fichero de TXT y confirmar que despues de que ha sido procesado en la cola de indexación puedes localizarlo por el contenido.

Cuando este paso este funcionando, podremos hablar de ficheros PDF y otros formatos.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest