Page 1 of 1

Problemas previsualización con versión 6.3.10

Posted: Thu Jul 01, 2021 3:34 pm
by dpm2021
Buenas tardes:
Estoy trabajando en la instalación de OpenKM, versión de la Comunidad 6.3.10, sobre plataforma Windows (Server 2019) y observo que la previsualización de documentos de Microsoft Office (Word y Excel) no funciona.
La documentación que he consultado indica que la clave system.openoffice.path debe estar correctamente configurada, pero no la encuentro en esta versión.
¿Alguien se ha encontrado con este mismo problema?
Gracias de antemano y un saludo.

Re: Problemas previsualización con versión 6.3.10

Posted: Fri Jul 02, 2021 12:12 pm
by dpm2021
Por lo que he podido comprobar, si se hace una instalación limpia de la versión 6.3.10 el problema que impide la previsualización no puede corregirse porque falta la clave system.openoffice.path.
Sin embargo, si se hace una instalación limpia de la versión 6.3.9, la clave system.openoffice.path aparece, por lo que puede informarse con C:\tomcat-8.5.34\extras\LibreOfficePortable\App, lo que posibilita el que la previsualización funcione de forma correcta.
Una vez instalada la versión 6.3.9 con la configuración de previsualización correcta, se pueden aplicar las actualizaciones 6.3.10 y 6.3.11 y la previsualización funciona correctamente.
Un saludo.

Re: Problemas previsualización con versión 6.3.10

Posted: Sat Jul 03, 2021 6:47 pm
by jllort
Quick question for 6.3.10 and upper:
* Installation have been done in windows?
* Confirm the extras folder exist in tomcat folder?
* Problem is the configuration parameter is not set automatically with the right path?

Re: Problemas previsualización con versión 6.3.10

Posted: Mon Jul 05, 2021 9:25 am
by pavila
Por favor, descarga el instalador de nuevo y prueba a instalar. Ahora debería aparecer la propiedad de configuración en el fichero OpenKM.cfg

Un saludo.

Re: Problemas previsualización con versión 6.3.10

Posted: Tue Jul 06, 2021 12:35 pm
by dpm2021
Hi, Pavila:
Yes, with the new installer the preview works correctly.
Thank you.

Re: Problemas previsualización con versión 6.3.10

Posted: Tue Jul 06, 2021 12:38 pm
by pavila
Great :)