servicio openKM no arranca en windows 03-may-2021

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
lfepacha
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Mon May 03, 2021 10:28 pm

servicio openKM no arranca en windows 03-may-2021

Post by lfepacha »

Por favor su ayuda, Instale al mediados de marzo del 2021, la versión openKM 6.3.10 versionn community , tomcat 8.5.34 en windows 10 y venia trabajando sin novedad. Hoy lunes 03.may-2021, trato de arrancar el servicio de windows openKM desde los servicios de windows, pero me sale una pantalla de error (ver archivos adjuntos)
Adjunto el contenido de catalina.log. y el png del mensaje de error de windows.

Gracias de antemano su tiempo y su gestión
Attachments
mensaje.png
catalina.2021-05-03.zip
(6.96 KiB) Downloaded 12 times
lfepacha
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Mon May 03, 2021 10:28 pm

Re: servicio openKM no arranca en windows 03-may-2021

Post by lfepacha »

El problema fue el JDK, creo que se actualizo la version automaticamente , borre y volvi a instalar el JDK y se arreglo, sin embargo perdi toda la informacion : taxonomia, reportes, metadatos ...etc.. Eche mano de un respaldo y estoy operativo de nuevo.
Sin embargo la linea de estado me marca que tengo usado 0(cero) bytes , no se si hay que actualizar algun contador ???

GRacias
jllort
Moderator
Moderator
Posts: 11474
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: servicio openKM no arranca en windows 03-may-2021

Post by jllort »

En estos casos raros te aconsejamos arrancar desde la terminal con el comando:
catalina.bat run

Y la salida de la consola te proporcionará una idea de lo que esta pasando.

Sobre que se hayan borrado ficheros ... etc... casi seguro que has tocado algo mas -> como el OpenKM.cfg -> hibernate.hbm2ddl=create -> si has hecho algo de este estilo lo que estas haciendo es resetear la instalación. Para perder todos los datos tienes que hacer algo de este estilo, sino es literalmente imposible.

Como sugerencia -> la copia de seguridad siempre te salvará la vida, esto es lo mas importante de todo, porque los equipos, por buenos que sean, con el tiempo terminan fallando y a veces sin avisar.
lfepacha
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Mon May 03, 2021 10:28 pm

Re: servicio openKM no arranca en windows 03-may-2021

Post by lfepacha »

Gracias la respuesta

EN realidad si lo puse en create nuevamente ....jejej pense que asi se reiniciaban SOLO los directorios del repository pero se fue todo ....el respaldo salvo !!!! . Respecto a lo que te decía en la línea de estado me sale como que tengo usados 0 bytes y antes me salía 29.9 MB, no se si luego me podrá ocasionar algún problema, es como si no estuviera actualizado algún registro donde te lleva esa información

Saludos
jllort
Moderator
Moderator
Posts: 11474
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: servicio openKM no arranca en windows 03-may-2021

Post by jllort »

Si nos haces una captura de pantalla de esto de los 0 bytes igual te puedo intentar explicar la razón.
lfepacha
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Mon May 03, 2021 10:28 pm

Re: servicio openKM no arranca en windows 03-may-2021

Post by lfepacha »

ADjunto el archivo

Gracias
Attachments
percent usado.png
jllort
Moderator
Moderator
Posts: 11474
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: servicio openKM no arranca en windows 03-may-2021

Post by jllort »

Me lo imaginaba, pero quería estar seguro. No te preocupes ni un segundo por eso. En la aplicación intentamos calcular el tamaño del repositorio de un usuario ( digo intentamos porque el calculo se hace sobre la marcha al añadir, modificar o eliminar ficheros vamos actualizando valores -> calcularlo para cada usuario del tiron en segun que repositorios sería demoledor ). La forma de calcular hace que en ciertos escenarios el resultado no sea correcto, incluso a veces hemos visto algún resultado negativo ( esto tiene relación con la lógica de cálculo que tiene algun fallo que se nos escapa ).

Como conclusión, no te preocupes por este valor, si has importado los ficheros desde la utilidad de importación, los ha importado un usuario especial que se ejecuta en background ( el usuario system ) y por lo tanto al usuario okmAdmin no se le ha asignado ningún documento ( esta es la explicación más probable de tu caso, no es la única pero tampoco me quiero alargar innecesariamente ). Finalmente, no te preocupes esto es un dato poco relevante que muchas veces hemos tenido la tentación de eliminarlo, porque le vemos más problemas que ventajas ( todo aquello que supone un lartre para el rendimiento es susceptible de ser eliminado y esta es una característica de este tipo ). En realidad sería mucho más interesante calcular el tamaño que consume un usuario bajo demanda -> esto tiene una penalización puntual ( cuando se realiza la solicitud ) y no constante en toda la aplicación.

Espero que la respuesta te ayude en algo.
couponstycoon
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Mon May 24, 2021 12:13 pm
Contact:

Re: servicio openKM no arranca en windows 03-may-2021

Post by couponstycoon »

thanks for the info :)
Post Reply