Page 1 of 1

Datos no Importados correctamente

Posted: Fri May 03, 2019 8:41 am
by fjjuanes
Hola a todos.

Comparto mi situación:

Vengo de OpenKM 6.3.1 con base de datos embebida (hypersonic)
Ahora tengo Openkm 6.3.8 con MariaDB

Todo en windows 7 x64

Realicé una instalación limpia desde 0 con el instalador .jar de la web y parecía todo Correcto.

Hice la exportación con metadatos e historia y la posterior importación de los datos en el nuevo repositorio marcando todos los checks (Metadata, History, Restore UUIDs)

Aparentemente, se hizo correctamente( muestra la historia, los usuarios que modificaron cada versión…), no dio ningún error. Pero revisando posteriormente he notado que faltan diversos documentos sin ningún patrón aparente, ya que son archivos .doc, .xls … con versiones, sin versiones…

¿Qué puedo hacer para recuperarlos? ¿Puedo realizar una importación de nuevo sin “sobrescribir lo existente? ¿Puedo separar los archivos que no se han importados y volver a importarlos? ¿desmarco la opción Restore UUIDs?

Gracias de antemano, un saludo.

EDIT: He localizado en la exportación, archivos que faltan. Respetando la estructura de direcotorios(Carpeta1/carpeta2... y los 4 archivos que genera la exportacíon por cada documento), los he importado, y aparecen el OpenKM pero con 0 bytes...

Image

Re: Datos no Importados correctamente

Posted: Sat May 04, 2019 7:42 am
by jllort
Cuando el objeto existe por defecto se lo salta y no continua procesándolo. Lo que es un tanto estraño es que tengas objetos ( documentos por lo que dices ) con un tamaño de 0. Seguro que al exportar has exportado todos los ficheros de la misma forma ( con el histórico ) ?

Si no representan un volúmen muy elevado, lo mejor es borrar los ficheros que no se han importado correctamente y centrarse en la importación de estos nuevamente (igual en una carpeta distinta de la taxonomía para luego moverlos al destino final )

Re: Datos no Importados correctamente

Posted: Sat May 04, 2019 1:15 pm
by fjjuanes
Perdona, que a lo mejor me he explicado mal. La exportación se realizó correctamente. Veo los documentos que faltan, con su tamaño y su metadata...todo como los demás archivos. Lo que pasa es que no los ha importado en la nueva instalación, no están ni listados en la taxonomía.

Cuando me aparecen con 0 bytes, es al importar de nuevo estos archivos que faltan, que tengo localizados en la exportación que hice anteriormente

Re: Datos no Importados correctamente

Posted: Sun May 05, 2019 8:16 am
by jllort
Si tienes identificados los documentos, bórralos de OpenKM ( acuérdate de limpiar la papelera después ) y vuelve a intentar importarlos. En el path tienen algún & o nombre con mas de dos espacios ... alguna característica del estilo que te estoy comentando.

Re: Datos no Importados correctamente

Posted: Mon May 06, 2019 3:52 pm
by fjjuanes
Gracias por tu respuesta.

Efectivamente como comentas, los archivos tienen doble espacio y también el símbolo & (justamente los 2 archivos que he probado a volver a importar)

Hoy no he podido hacer más pruebas, pero ¿hay solución para estos casos?

Re: Datos no Importados correctamente

Posted: Fri May 10, 2019 10:38 am
by jllort
El problema es que estas exportando de una version anterior a la que importas y por el camino este problema se soluciono en alguna de las actualizaciones. Esto implica que en la ultima version ya no espera ficheros del tipo con dos espacios etc... porque en el repositorio ya esta arreglado pero como es una versión antigua exporta con este formato que a la ultima versión no le gusta.

2 caminos que al final son el mismo:
- instalar un openkm limpio pero de una version anterior, exportar y exportar y al final de todo subir de version
- subir el que tienes ahora mismo y después exportar