Page 1 of 1

Falla tomcat

Posted: Fri Jan 18, 2019 6:22 pm
by aslo611
Estimados,

Estoy intentando instalar el OpenKM en Ubuntu por primera vez y tengo un problema con el tomcat; cuando realizo la instalación del openkm.jar se instala automáticamente la versión de tomcat 8.5.24, el problema es que voy a validar los servicios instalados por medio del comando (sin comillas) "ls -lisa /etc/init.d/" pero no me aparece, posteriormente intento instalar de nuevo el OpenKM pero dice que no se puede porque la carpeta de tomcat ya existe y me confirma que se encuentra en dicha versión. He intentado instalar otras versiones de tomcat pero no es compatible con OpenKM, agradezco cualquier tipo de apoyo para poder solución pronto, muy amables.

Re: Falla tomcat

Posted: Mon Jan 21, 2019 5:49 pm
by lnovoa
Hola,

has probado hacer directamente:
$ /etc/init.d/tomcat start

Puedes eliminar todo el directorio tomcat y volver a realizar la instalación.

Si puedes detallar los pasos que has realizado o capturas de pantalla mejor.

Re: Falla tomcat

Posted: Tue Jan 22, 2019 6:43 pm
by jllort
No tienes que instalar el tomcat que viene en los repositorio de Ubuntu, sino que la aplicación ya te instalará en tu ubicación actual un tomcat y te lo registrará como servicio ( este es un tomcat con alguna modificaciones ).

Te aconsejo que mires el video que tenemos en la secció de descargas : https://www.youtube.com/watch?time_cont ... _CMEpHkwqA

Fíjate que el usuario con el que instalamos la aplicacion es el usuario root ( que es el que va a tener privilegios para registrar servicios etc... )

Re: Falla tomcat

Posted: Tue Jan 29, 2019 9:52 pm
by aslo611
Agradezco la ayuda, confirmo inicialmente que ya probé ejecutando el servicio pero no funciona (esto lo hice antes de eliminar la carpeta de tomcat en la misma ruta del OpenKM) igualmente adjunto el pantallazo. "servicio tomcat.png"

Posteriormente ejecuto la versión de OKMInstaller y se descarga e instala automáticamente la versión de tomcat 8.5.24 "instalación.png" aunque después valido nuevamente los servicios y no aparece el tomcat.

Si se requiere información o pantallazos adicionales no duden en solicitarlos, muy amables.

Re: Falla tomcat

Posted: Wed Jan 30, 2019 7:49 pm
by jllort
Te has fijado en los privilegios de la carpeta tomcat ?
Creaste anteriormente un usuario openkm y iniciaste el proceso de instalacion en /home/openkm ( el instalador presume que existe un usuario openkm previsamente en el sistema y establece la seguridad y el script con este usuario ) ?

Re: Falla tomcat

Posted: Mon Feb 04, 2019 2:36 pm
by aslo611
Te cuento que reinstalé el sistema operativo ya que no había realizado el proceso con el usuario de openkm porque no tenía la claridad, en este momento lo hago todo con el usuario "openkm" y siempre para iniciar la línea de comandos en el momento de ejecutar utilizo el comando "sudo su" pero te comento que tampoco se instaló el tomcat como servicio, te adjunto los pantallazos en donde te confirmo lo sighuiente:

Pantalla 1: Te evidencio que el proceso se está realizando en la ruta /home/openkm
Pantalla 2: Los permisos sobre la carpeta tomcat ubicada en /home/openkm/tomcat-8.5.24
Pantalla 3: Todos los servicios menos el tomcat

Cualquier apoyo es agradecido.

Re: Falla tomcat

Posted: Thu Feb 07, 2019 7:10 pm
by jllort
El servicio se llama openkm. En las ultimas versiones decidimos cambiar el nombre.

Code: Select all

sudo service openkm start

Re: Falla tomcat

Posted: Fri Feb 08, 2019 1:56 pm
by aslo611
Te cuento que ejecuté el comando que me indicas pero sigue sin iniciarse el servicio de tomcat (pensaba que el servicio de openkm de pronto iba a iniciar el de tomcat pero no fue así). Sigo teniendo el problema de que no se inicia el servicio de tomcat; te adjunto pantallazo de como sale en el vídeo y de como me sale en mi terminal, muchas gracias.

Re: Falla tomcat

Posted: Sat Feb 09, 2019 4:17 pm
by jllort
En la última captura de pantalla has ejecutado primero el servicio llamado openkm ( que no te ha devuelto ningún resultado por la terminal -> cosa estraña ) y el tomcat que no existe.

Edita el fichero openkm y mira a ver si los valores de path etc... cuadran. Confirma que el propietario de la carpeta del tomcat es el openkm.

Si con el usuario openkm ejecutas el tomcat por la terminal te funciona ( ojo con el usuario openkm ) ?

Code: Select all

./bin/catalina.sh run 
Seguro que despues de ejecutar el servicio que se llama openkm no se esta arrancando ninguna aplicación java?

Code: Select all

ps ax | grep java