No inicia servicio de OpenKM

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

No inicia servicio de OpenKM

Post by Adolfo » Mon Jun 19, 2017 6:06 pm

Hola he intentado en varias ocasiones instalar openkm en windows 64bits pro con mariadb sin embargo todo bien hasta el final en el cual no se puede iniciar el servicio de openkm:

Code: Select all

  main] INFO  com.openkm.installer.b.l - Install service: [C:\OKMInstaller\tomcat-7.0.61\bin\service.bat, install, OpenKM]
2017-06-19 12:56:08,645 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\service.bat, install, OpenKM]
2017-06-19 12:56:09,347 [    main] INFO  com.openkm.installer.Main - Installing the service 'OpenKM' ...
2017-06-19 12:56:09,347 [    main] INFO  com.openkm.installer.Main - Using CATALINA_HOME:    "C:\OKMInstaller\tomcat-7.0.61"
2017-06-19 12:56:09,363 [    main] INFO  com.openkm.installer.Main - Using CATALINA_BASE:    "C:\OKMInstaller\tomcat-7.0.61"
2017-06-19 12:56:09,363 [    main] INFO  com.openkm.installer.Main - Using JAVA_HOME:        "C:\Program Files\Java\jdk1.8.0_131"
2017-06-19 12:56:09,378 [    main] INFO  com.openkm.installer.Main - Using JRE_HOME:         "C:\Program Files\Java\jdk1.8.0_131\jre"
2017-06-19 12:56:09,378 [    main] INFO  com.openkm.installer.Main - Using JVM:              "C:\Program Files\Java\jdk1.8.0_131\jre\bin\server\jvm.dll"
2017-06-19 12:56:09,394 [    main] INFO  com.openkm.installer.Main - Failed installing 'OpenKM' service
2017-06-19 12:56:09,394 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-XX:+UseConcMarkSweepGC"]
2017-06-19 12:56:09,597 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Djava.awt.headless=true"]
2017-06-19 12:56:09,768 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Dfile.encoding=utf-8"]
2017-06-19 12:56:09,955 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Dmail.mime.ignoreunknownencoding=true"]
2017-06-19 12:56:10,143 [    main] INFO  com.openkm.installer.Main - Directory cleanup
2017-06-19 12:56:10,143 [    main] INFO  com.openkm.installer.b - Directory cleanup C:\OKMInstaller\installer.tmp
2017-06-19 12:56:10,236 [    main] INFO  com.openkm.installer.b - ### FINISH INSTALL ###
2017-06-19 12:56:10,267 [    main] INFO  com.openkm.installer.Main - Don't forget to create the database
2017-06-19 12:56:10,267 [    main] INFO  com.openkm.installer.Main - CREATE DATABASE okmdb DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_bin;
2017-06-19 12:56:10,299 [    main] INFO  com.openkm.installer.Main - CREATE USER openkm@localhost IDENTIFIED BY 'T4SnJtK67D8T';
2017-06-19 12:56:10,299 [    main] INFO  com.openkm.installer.Main - GRANT ALL ON okmdb.* TO openkm@localhost WITH GRANT OPTION;
he intentado iniciar manualmente el servicio pero no inicia.

Estare haciendo algo mal?

gracias.

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Tue Jun 20, 2017 12:28 pm

Mira a ver si en los servicios tienes un servicio llamado OpenKM ( es el que no se inicia verdad ? )
Lístame los ficheros que estan dentro del directorio tomcat/bin

Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

Re: No inicia servicio de OpenKM

Post by Adolfo » Tue Jun 20, 2017 3:15 pm

Hola, Si, el servicio esta listado como OpenKM pero al iniciar el servicio Windows me muestra la ventana de dialogo que no puede iniciar el servicio.

los archivos que estan en tomcat/bin son los siguientes:

Code: Select all

bootstrap.jar
 catalina-tasks.xml
 catalina.bat
 catalina.sh
 commons-daemon-native.tar.
 commons-daemon.jar
 configtest.bat
 configtest.sh
 convert.exe
 daemon.sh
 diffpdf
 diffpdf.x86
 digest.bat
 digest.sh
 ffmpeg
 ffmpeg.exe
 gsdll32.dll
 gswin32c.exe
 identify.exe
 inxi
 jvmtop.bat
 jvmtop.jar
 jvmtop.sh
 openkm.exe
 openkmw.exe
 pdf2swf
 pdf2swf.exe
 pdfimages
 pdfimages.exe
 phantomjs
 phantomjs.exe
 rasterize.js
 service
 service.bat
 setclasspath.bat
 setclasspath.sh
 setenv.bat
 setenv.sh
 shutdown.bat
 shutdown.sh
 startup.bat
 startup.sh
 strings.exe
 tcnative-1.dll
 tomcat-juli.jar
 tomcat-native.tar.gz
 tool-wrapper.bat
 tool-wrapper.sh
 version.bat
 version.sh
 wkhtmltopdf
 wkhtmltopdf.exe

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Wed Jun 21, 2017 11:43 am

Me faltan ficheros en este listado uno que se llame tomcat7.exe y tomcat7w.exe o similares. Tienes una carpeta x-86 y x-64 donde estan unos ficheros que tienes que copiar dentro ?

Se te ha registrado como servicio ? en caso afirmativo que nombre tiene ?

Mírate esta parte de la documentación para que entiendas que es lo que estamso buscando https://docs.openkm.com/kcenter/view/ok ... asaservice

Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

Re: No inicia servicio de OpenKM

Post by Adolfo » Wed Jun 21, 2017 2:15 pm

Ahh, si, tomcat esta incompleto, ni siquiera se registro su servicio, mm voy a continuar con la instalación manual, habia usado el instalador para instalar openKM pero creo que aún no esta completo.

voy a ver que me falta para hacerlo manualmente.
gracias!!!

jllort
Moderator
Moderator
Posts: 9642
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Fri Jun 23, 2017 9:32 am

Parece que tenemos algún problema con el instalador, lo revisaremos, porque lo suyo es utilizar la herramienta para instalar la aplicación de forma automática.

pavila
Moderator
Moderator
Posts: 3032
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: No inicia servicio de OpenKM

Post by pavila » Tue Jun 27, 2017 12:46 pm

Hay una nueva versión del instalador desde hace una semana. Por favor, prueba con esa versión. Ten en cuenta que el servicio ahora se llama "openkm" si estás en Linux y "OpenKM" en caso de Windows.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests