No inicia servicio de OpenKM

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

No inicia servicio de OpenKM

Post by Adolfo » Mon Jun 19, 2017 6:06 pm

Hola he intentado en varias ocasiones instalar openkm en windows 64bits pro con mariadb sin embargo todo bien hasta el final en el cual no se puede iniciar el servicio de openkm:

Code: Select all

  main] INFO  com.openkm.installer.b.l - Install service: [C:\OKMInstaller\tomcat-7.0.61\bin\service.bat, install, OpenKM]
2017-06-19 12:56:08,645 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\service.bat, install, OpenKM]
2017-06-19 12:56:09,347 [    main] INFO  com.openkm.installer.Main - Installing the service 'OpenKM' ...
2017-06-19 12:56:09,347 [    main] INFO  com.openkm.installer.Main - Using CATALINA_HOME:    "C:\OKMInstaller\tomcat-7.0.61"
2017-06-19 12:56:09,363 [    main] INFO  com.openkm.installer.Main - Using CATALINA_BASE:    "C:\OKMInstaller\tomcat-7.0.61"
2017-06-19 12:56:09,363 [    main] INFO  com.openkm.installer.Main - Using JAVA_HOME:        "C:\Program Files\Java\jdk1.8.0_131"
2017-06-19 12:56:09,378 [    main] INFO  com.openkm.installer.Main - Using JRE_HOME:         "C:\Program Files\Java\jdk1.8.0_131\jre"
2017-06-19 12:56:09,378 [    main] INFO  com.openkm.installer.Main - Using JVM:              "C:\Program Files\Java\jdk1.8.0_131\jre\bin\server\jvm.dll"
2017-06-19 12:56:09,394 [    main] INFO  com.openkm.installer.Main - Failed installing 'OpenKM' service
2017-06-19 12:56:09,394 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-XX:+UseConcMarkSweepGC"]
2017-06-19 12:56:09,597 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Djava.awt.headless=true"]
2017-06-19 12:56:09,768 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Dfile.encoding=utf-8"]
2017-06-19 12:56:09,955 [    main] INFO  com.openkm.installer.b.d - Execute: [C:\OKMInstaller\tomcat-7.0.61\bin\OpenKM, //US//OpenKM, ++JvmOptions="-Dmail.mime.ignoreunknownencoding=true"]
2017-06-19 12:56:10,143 [    main] INFO  com.openkm.installer.Main - Directory cleanup
2017-06-19 12:56:10,143 [    main] INFO  com.openkm.installer.b - Directory cleanup C:\OKMInstaller\installer.tmp
2017-06-19 12:56:10,236 [    main] INFO  com.openkm.installer.b - ### FINISH INSTALL ###
2017-06-19 12:56:10,267 [    main] INFO  com.openkm.installer.Main - Don't forget to create the database
2017-06-19 12:56:10,267 [    main] INFO  com.openkm.installer.Main - CREATE DATABASE okmdb DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_bin;
2017-06-19 12:56:10,299 [    main] INFO  com.openkm.installer.Main - CREATE USER openkm@localhost IDENTIFIED BY 'T4SnJtK67D8T';
2017-06-19 12:56:10,299 [    main] INFO  com.openkm.installer.Main - GRANT ALL ON okmdb.* TO openkm@localhost WITH GRANT OPTION;
he intentado iniciar manualmente el servicio pero no inicia.

Estare haciendo algo mal?

gracias.

jllort
Moderator
Moderator
Posts: 9702
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Tue Jun 20, 2017 12:28 pm

Mira a ver si en los servicios tienes un servicio llamado OpenKM ( es el que no se inicia verdad ? )
Lístame los ficheros que estan dentro del directorio tomcat/bin

Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

Re: No inicia servicio de OpenKM

Post by Adolfo » Tue Jun 20, 2017 3:15 pm

Hola, Si, el servicio esta listado como OpenKM pero al iniciar el servicio Windows me muestra la ventana de dialogo que no puede iniciar el servicio.

los archivos que estan en tomcat/bin son los siguientes:

Code: Select all

bootstrap.jar
 catalina-tasks.xml
 catalina.bat
 catalina.sh
 commons-daemon-native.tar.
 commons-daemon.jar
 configtest.bat
 configtest.sh
 convert.exe
 daemon.sh
 diffpdf
 diffpdf.x86
 digest.bat
 digest.sh
 ffmpeg
 ffmpeg.exe
 gsdll32.dll
 gswin32c.exe
 identify.exe
 inxi
 jvmtop.bat
 jvmtop.jar
 jvmtop.sh
 openkm.exe
 openkmw.exe
 pdf2swf
 pdf2swf.exe
 pdfimages
 pdfimages.exe
 phantomjs
 phantomjs.exe
 rasterize.js
 service
 service.bat
 setclasspath.bat
 setclasspath.sh
 setenv.bat
 setenv.sh
 shutdown.bat
 shutdown.sh
 startup.bat
 startup.sh
 strings.exe
 tcnative-1.dll
 tomcat-juli.jar
 tomcat-native.tar.gz
 tool-wrapper.bat
 tool-wrapper.sh
 version.bat
 version.sh
 wkhtmltopdf
 wkhtmltopdf.exe

jllort
Moderator
Moderator
Posts: 9702
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Wed Jun 21, 2017 11:43 am

Me faltan ficheros en este listado uno que se llame tomcat7.exe y tomcat7w.exe o similares. Tienes una carpeta x-86 y x-64 donde estan unos ficheros que tienes que copiar dentro ?

Se te ha registrado como servicio ? en caso afirmativo que nombre tiene ?

Mírate esta parte de la documentación para que entiendas que es lo que estamso buscando https://docs.openkm.com/kcenter/view/ok ... asaservice

Adolfo
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Mon Jun 19, 2017 5:21 pm

Re: No inicia servicio de OpenKM

Post by Adolfo » Wed Jun 21, 2017 2:15 pm

Ahh, si, tomcat esta incompleto, ni siquiera se registro su servicio, mm voy a continuar con la instalación manual, habia usado el instalador para instalar openKM pero creo que aún no esta completo.

voy a ver que me falta para hacerlo manualmente.
gracias!!!

jllort
Moderator
Moderator
Posts: 9702
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Fri Jun 23, 2017 9:32 am

Parece que tenemos algún problema con el instalador, lo revisaremos, porque lo suyo es utilizar la herramienta para instalar la aplicación de forma automática.

pavila
Moderator
Moderator
Posts: 3036
Joined: Tue Dec 11, 2007 6:02 pm
Location: Alicante, Spain
Contact:

Re: No inicia servicio de OpenKM

Post by pavila » Tue Jun 27, 2017 12:46 pm

Hay una nueva versión del instalador desde hace una semana. Por favor, prueba con esa versión. Ten en cuenta que el servicio ahora se llama "openkm" si estás en Linux y "OpenKM" en caso de Windows.

angelcitysakura
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Sun Nov 26, 2017 1:25 am

Re: No inicia servicio de OpenKM

Post by angelcitysakura » Sun Nov 26, 2017 1:29 am

Hola
Segui todos los pasos de instalacion y obtengo un error

type Informe de estado

mensaje /OpenKM

descripción El recurso requerido no está disponible.

Entro en el archivo C:\tomcat-7.0.61\bin\openkm y el comando me aarroja la siguiente información

nov 25, 2017 10:22:40 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFORMACIÓN: Cargada la biblioteca nativa APR de Apache Tomcat 1.1.33 con la versión APR 1.5.1.
nov 25, 2017 10:22:40 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFORMACIÓN: Capacidades APR: IPv6 [true], enviar fichero [true], aceptar filtros [false], aleatorio [true].
nov 25, 2017 10:22:42 PM org.apache.catalina.core.AprLifecycleListener initializeSSL
INFORMACIÓN: OpenSSL inicializado correctamente (OpenSSL 1.0.1m 19 Mar 2015)
nov 25, 2017 10:22:42 PM org.apache.coyote.AbstractProtocol init
INFORMACIÓN: Initializing ProtocolHandler ["http-apr-0.0.0.0-8080"]
nov 25, 2017 10:22:42 PM org.apache.coyote.AbstractProtocol init
GRAVE: Failed to initialize end point associated with ProtocolHandler ["http-apr-0.0.0.0-8080"]
java.lang.Exception: Ligado de conector fall├│: [730013] Intento de acceso a un socket no permitido por sus permisos de acceso.
at org.apache.tomcat.util.net.AprEndpoint.bind(AprEndpoint.java:453)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:649)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:978)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:821)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:638)
at org.apache.catalina.startup.Catalina.load(Catalina.java:663)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:454)

nov 25, 2017 10:22:42 PM org.apache.catalina.core.StandardService initInternal
GRAVE: No pude inicializar el conector [Connector[HTTP/1.1-8080]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8080]]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:821)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:638)
at org.apache.catalina.startup.Catalina.load(Catalina.java:663)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:454)
Caused by: org.apache.catalina.LifecycleException: Fall├│ la inicializaci├│n del manejador de protocolo
at org.apache.catalina.connector.Connector.initInternal(Connector.java:980)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
... 12 more
Caused by: java.lang.Exception: Ligado de conector fall├│: [730013] Intento de acceso a un socket no permitido por sus permisos de acceso.
at org.apache.tomcat.util.net.AprEndpoint.bind(AprEndpoint.java:453)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:649)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:978)
... 13 more

nov 25, 2017 10:22:42 PM org.apache.coyote.AbstractProtocol init
INFORMACIÓN: Initializing ProtocolHandler ["ajp-apr-127.0.0.1-8009"]
nov 25, 2017 10:22:42 PM org.apache.coyote.AbstractProtocol init
GRAVE: Failed to initialize end point associated with ProtocolHandler ["ajp-apr-127.0.0.1-8009"]
java.lang.Exception: Ligado de conector fall├│: [730013] Intento de acceso a un socket no permitido por sus permisos de acceso.
at org.apache.tomcat.util.net.AprEndpoint.bind(AprEndpoint.java:453)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:649)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:978)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:821)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:638)
at org.apache.catalina.startup.Catalina.load(Catalina.java:663)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:454)

nov 25, 2017 10:22:42 PM org.apache.catalina.core.StandardService initInternal
GRAVE: No pude inicializar el conector [Connector[AJP/1.3-8009]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[AJP/1.3-8009]]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:821)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:638)
at org.apache.catalina.startup.Catalina.load(Catalina.java:663)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:454)
Caused by: org.apache.catalina.LifecycleException: Fall├│ la inicializaci├│n del manejador de protocolo
at org.apache.catalina.connector.Connector.initInternal(Connector.java:980)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
... 12 more
Caused by: java.lang.Exception: Ligado de conector fall├│: [730013] Intento de acceso a un socket no permitido por sus permisos de acceso.
at org.apache.tomcat.util.net.AprEndpoint.bind(AprEndpoint.java:453)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:649)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:978)
... 13 more

nov 25, 2017 10:22:42 PM org.apache.catalina.startup.Catalina load
INFORMACIÓN: Initialization processed in 3295 ms
nov 25, 2017 10:22:43 PM org.apache.catalina.core.StandardService startInternal
INFORMACIÓN: Arrancando servicio Catalina
nov 25, 2017 10:22:43 PM org.apache.catalina.core.StandardEngine startInternal
INFORMACIÓN: Starting Servlet Engine: Apache Tomcat/7.0.61
nov 25, 2017 10:22:43 PM org.apache.catalina.startup.HostConfig deployWAR
INFORMACIÓN: Despliegue del archivo C:\tomcat-7.0.61\webapps\OpenKM.war de la aplicación web
nov 25, 2017 10:24:06 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFORMACIÓN: validateJarFile(C:\tomcat-7.0.61\webapps\OpenKM\WEB-INF\lib\servlet-api-2.5-20081211.jar) - jar not loaded. See Servlet Spec 3.0, section 10.7.2. Offending class: javax/servlet/Servlet.class
nov 25, 2017 10:24:06 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFORMACIÓN: validateJarFile(C:\tomcat-7.0.61\webapps\OpenKM\WEB-INF\lib\servlet-api-6.0.36.jar) - jar not loaded. See Servlet Spec 3.0, section 10.7.2. Offending class: javax/servlet/Servlet.class


Ayuda!

jllort
Moderator
Moderator
Posts: 9702
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: No inicia servicio de OpenKM

Post by jllort » Sat Dec 02, 2017 7:49 pm

Has cambiado el puerto del tomcat ? Intento de acceso a un socket no permitido por sus permisos de acceso. porque parece que no puede hacer el binding por falta de privilegios sobre ese puerto. Esto tiene toda la pinta de ser algo de la seguridad en el windows ( o con el usuario con el que estas arrancando la aplicación, aunque no debería )

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest