[Resuelto] Problemas con OpenOffice + OpenKM como servicio

Problemas con la instalación de OpenKM? No problemo, la solución está más cerca de lo que piensas.
Forum rules
Por favor, antes de preguntar algo consulta el wiki de documentación o utiliza la función de búsqueda del foro. Recuerda que no tenemos una bola de cristal ni poderes mentales, o sea que que para informar sobre un error es necesario que nos indiques tanto la versión de OpenKM que usas como la del navegador y sistema operativo. Para más información consulta Cómo informar de fallos de forma efectiva.
Post Reply
fdelvalle
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Sat Oct 11, 2014 6:39 pm

[Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by fdelvalle » Sat Oct 11, 2014 6:47 pm

Hola,
Os pongo en situación: es una instalación nueva de OpenKM en un Windows Server Essentials 2012 de 64 bits, que he llevado a cabo de la siguiente forma:

1) He instalado OpenKM 6.3.0 usando el setup de windows
2) He instalado y configurado OpenOffice 4.4.1, además de pdf2swf con las SWFTools.
3) He seguido la guía para instalar OpenKM como servicio a partir del punto 6. Para poder hacerlo previamente he tenido que copiar en el directorio $TOMCAT/bin el contenido de la carpeta $TOMCAT/bin/win-x64.

En este punto, puedo arrancar OpenKM de dos formas: con el icono del escritorio o arrancando el servicio. En el primer caso, la previsualización de documentos funciona perfectamente, pero si lo arranco como servicio, da errores de este tipo:
Conversion: Error in application/vnd.openxmlformats-offidocument.wordprocessing.document to PDF conversion

El resto parece funcionar perfectamente. Creo que el error es que al arrancar OpenKM como servicio no es capaz de crear el proceso de OpenOffice, si miro el administrador de procesos, después de arrancar normalmente me aparece siempre un proceso soffice.exe, pero al arrancar como servicio no.

¿Hay que configurar el servicio de alguna forma para que sea capaz de arrancar el proceso de OpenOffice?


Gracias
Last edited by fdelvalle on Thu Oct 16, 2014 6:57 am, edited 1 time in total.

jllort
Moderator
Moderator
Posts: 9647
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: Problemas con OpenOffice + OpenKM como servicio

Post by jllort » Tue Oct 14, 2014 11:16 am

fíjate que el setenv.bat pone el path del sigar en el entorno de ejecución, cuando lo arrancas como servicio tienes que tenerlo como variables globales, creo que metiendolo como parte del path ( variable de entorno global ) ya te tendría que funcionar. Si no es así dínoslo y lo miraré con mas detalle.

fdelvalle
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Sat Oct 11, 2014 6:39 pm

Re: Problemas con OpenOffice + OpenKM como servicio

Post by fdelvalle » Thu Oct 16, 2014 6:56 am

Era eso.
Fallo mío: había metido por error la carpeta de sigar en las variables de entorno del usuario, y no en las del sistema.

¡Muchas gracias!

rnayala
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Wed Jul 22, 2015 7:12 pm

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by rnayala » Wed Jul 22, 2015 7:13 pm

Como configuraste el openOffice, ya que yo no he logrado hacer funcionar la previsualizacion?

jllort
Moderator
Moderator
Posts: 9647
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by jllort » Wed Jul 22, 2015 8:16 pm

Pégale un ojo a esta página http://wiki.openkm.com/index.php/Previsualization

rnayala también lo estas configurando en un windows ? que parametro de configuracion tienes en el system.openoffice.path ?

eduar
Junior Boarder
Junior Boarder
Posts: 36
Joined: Mon Jun 22, 2015 9:03 pm

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by eduar » Wed Jul 22, 2015 9:53 pm

Me sale todo en OK en la configuración de las variables de OpenKM, pero al ejecutarlo me sale el siguiente error

com.openkm.servlet.RepositoryStartupServlet - failed to start and connect
org.artofsolving.jodconverter.office.OfficeException: failed to start and connect

Me podrías ayudar a solucionar el problema?

jllort
Moderator
Moderator
Posts: 9647
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by jllort » Fri Jul 24, 2015 3:20 pm

Pon aquí los parametros de configuracion del openffice y un poco mas de log para ver si con una traza mas completa le vemos algo.

eduar
Junior Boarder
Junior Boarder
Posts: 36
Joined: Mon Jun 22, 2015 9:03 pm

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by eduar » Wed Jun 08, 2016 8:50 pm

Hola aqui esta el log

Code: Select all

2
2016-06-08 15:38:33,215 [localhost-startStop-1] INFO  com.openkm.util.DocConverter- *** Build Office Manager ***
2016-06-08 15:38:33,215 [localhost-startStop-1] INFO  com.openkm.util.DocConverter- system.openoffice.path=C:/Program Files (x86)/OpenOffice 4
2016-06-08 15:38:33,215 [localhost-startStop-1] INFO  com.openkm.util.DocConverter- system.openoffice.tasks=200
2016-06-08 15:38:33,215 [localhost-startStop-1] INFO  com.openkm.util.DocConverter- system.openoffice.port=2002
2016-06-08 15:38:33,247 [localhost-startStop-1] INFO  org.artofsolving.jodconverter.office.ProcessPoolOfficeManager- ProcessManager implementation is SigarProcessManager
2016-06-08 15:38:33,247 [localhost-startStop-1] WARN  com.openkm.servlet.RepositoryStartupServlet- failed to start and connect
org.artofsolving.jodconverter.office.OfficeException: failed to start and connect
	at org.artofsolving.jodconverter.office.ManagedOfficeProcess.startAndWait(ManagedOfficeProcess.java:64)
	at org.artofsolving.jodconverter.office.PooledOfficeManager.start(PooledOfficeManager.java:101)
	at org.artofsolving.jodconverter.office.ProcessPoolOfficeManager.start(ProcessPoolOfficeManager.java:62)
	at com.openkm.util.DocConverter.start(DocConverter.java:190)
	at com.openkm.servlet.RepositoryStartupServlet.start(RepositoryStartupServlet.java:279)
	at com.openkm.servlet.RepositoryStartupServlet.init(RepositoryStartupServlet.java:127)
	at javax.servlet.GenericServlet.init(GenericServlet.java:158)
	at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1284)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1197)
	at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1087)
	at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5210)
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5493)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
	at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1073)
	at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1857)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.util.concurrent.ExecutionException: java.lang.UnsatisfiedLinkError: org.hyperic.sigar.ptql.SigarProcessQuery.create(Ljava/lang/String;)V
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.artofsolving.jodconverter.office.ManagedOfficeProcess.startAndWait(ManagedOfficeProcess.java:62)
	... 22 more
Caused by: java.lang.UnsatisfiedLinkError: org.hyperic.sigar.ptql.SigarProcessQuery.create(Ljava/lang/String;)V
	at org.hyperic.sigar.ptql.SigarProcessQuery.create(Native Method)
	at org.hyperic.sigar.ptql.ProcessQueryFactory.getQuery(ProcessQueryFactory.java:66)
	at org.hyperic.sigar.ptql.ProcessFinder.find(ProcessFinder.java:68)
	at org.hyperic.sigar.ptql.ProcessFinder.find(ProcessFinder.java:56)
	at org.artofsolving.jodconverter.process.SigarProcessManager.findPid(SigarProcessManager.java:42)
	at org.artofsolving.jodconverter.office.OfficeProcess.start(OfficeProcess.java:65)
	at org.artofsolving.jodconverter.office.OfficeProcess.start(OfficeProcess.java:60)
	at org.artofsolving.jodconverter.office.ManagedOfficeProcess.doStartProcessAndConnect(ManagedOfficeProcess.java:119)
	at org.artofsolving.jodconverter.office.ManagedOfficeProcess.access$000(ManagedOfficeProcess.java:31)
	at org.artofsolving.jodconverter.office.ManagedOfficeProcess$1.run(ManagedOfficeProcess.java:58)
	... 5 more
2016-06-08 15:38:33,262 [localhost-startStop-1] INFO  com.openkm.extension.core.ExtensionManager- Initialize and load plugins...
2016-06-08 15:38:33,606 [localhost-startStop-1] WARN  net.xeoh.plugins.base.impl.classpath.loader.FileLoader- Supplied path does not

jllort
Moderator
Moderator
Posts: 9647
Joined: Fri Dec 21, 2007 11:23 am
Location: Sineu - ( Illes Balears ) - Spain
Contact:

Re: [Resuelto] Problemas con OpenOffice + OpenKM como servicio

Post by jllort » Thu Jun 09, 2016 7:25 am

El openoffice esta en esta ruta C:/Program Files (x86)/OpenOffice 4 ?
Como estas arrancando OpenKM. Puedes probar a arrancarlo desde el terminar /bin/catalina.bat run ( a ver si desde aquí funciona )

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests