Search found 93 matches

by mamad
Thu May 16, 2019 6:59 am
Forum: Configuration
Topic: Path not exist error when login by a custom role
Replies: 3
Views: 75

Re: Path not exist error when login by a custom role

Thank you, i solved the problem
I should specify access to root folder for all of profiles i defined.
by mamad
Sat May 11, 2019 8:35 am
Forum: Configuration
Topic: Path not exist error when login by a custom role
Replies: 3
Views: 75

Re: Path not exist error when login by a custom role

also for some user this error appears with a differnet style !!! :
Capture2.PNG
by mamad
Sat May 11, 2019 7:54 am
Forum: Configuration
Topic: Path not exist error when login by a custom role
Replies: 3
Views: 75

Path not exist error when login by a custom role

Hi guys,
i made some roles and when i try to login by a user with that roles,the following error occurred :
Capture.PNG
Capture.PNG (11.22 KiB) Viewed 75 times
But when i change role of them to OKM_ADMIN or OKM_USER i will login correctly.
How fix this ?
Thanks in advance
by mamad
Sun May 05, 2019 6:01 am
Forum: Configuration
Topic: Enable/disable my extension by profiles
Replies: 2
Views: 50

Re: Enable/disable my extension by profiles

I guess i can do this by adding my extension to OKM_EXTENSION table some thing like : INSERT INTO OKM_EXTENSION (EXT_UUID,EXT_NAME) VALUES('Extension UUID','Extension Name'); But whats extension uuid ? how i set an uuid for my extension ? How generate it ? does it has a special format or just a stri...
by mamad
Sun May 05, 2019 5:54 am
Forum: Configuration
Topic: Enable/disable my extension by profiles
Replies: 2
Views: 50

Enable/disable my extension by profiles

Hi dear Jllort, Based on openkm documentations from here :https://docs.openkm.com/kcenter/view/okm-6.3-com/extending-frontend-ui.html , i created an extension and successfully add it to the Tab Document. The extensions will show correctly for each document in tab document panel but i don't want this...
by mamad
Sat May 04, 2019 8:14 pm
Forum: Configuration
Topic: Problem displaying the preview of MS Office files
Replies: 3
Views: 93

Re: Problem displaying the preview of MS Office files

restarting tomcat solved my problem
thank you
by mamad
Tue Apr 23, 2019 11:10 am
Forum: Configuration
Topic: Problem displaying the preview of MS Office files
Replies: 3
Views: 93

Re: Problem displaying the preview of MS Office files

this is the log created by this problem : 2019-04-23 06:02:12,861 [http-nio-0.0.0.0-8080-exec-20] [] ERROR c.o.s.frontend.ConverterServlet - Error in application/vnd.openxmlformats-officedocument.spreadsheetml.sheet to PDF conversion com.openkm.core.ConversionException: Error in application/vnd.open...
by mamad
Tue Apr 23, 2019 11:03 am
Forum: Configuration
Topic: Problem displaying the preview of MS Office files
Replies: 3
Views: 93

Problem displaying the preview of MS Office files

Hi guys, when i try to see the preview of Microsoft office files (.xlsx,.docx,etc) the following error appears instead of showing the preview of file : There was a problem with the conversion generation.please contact your OpenKM administrator. The preview works for .pdf files. Also when i try downl...
by mamad
Sun Apr 07, 2019 5:07 am
Forum: Configuration
Topic: Where Log data saved in database ?
Replies: 1
Views: 59

Where Log data saved in database ?

Hi guys,
I want to clear some log data of openkm but i cant find the table which hold log data.
Where this item saved in database ?
I'm using openkm 6.3 CE
Thanks in advance
by mamad
Mon Mar 25, 2019 8:10 am
Forum: Configuration
Topic: Make Version start from 0 ?
Replies: 3
Views: 152

Re: Make Version start from 0 ?

Thanks for your hint.
I simply change the starting version from 1.0 to 0.0 by changing getInitialVersionNumber() method inside MajorMinorReleaseVersionNumerationAdapter class :

Code: Select all

@Override
public String getInitialVersionNumber() {
        return "0.0";
	}
}
it was easy right ?:D
by mamad
Wed Mar 13, 2019 12:30 pm
Forum: Configuration
Topic: Make Version start from 0 ?
Replies: 3
Views: 152

Make Version start from 0 ?

Hi guys, I'm using openkm6.3.7-DEV community edition I want to know is it possible to make versions of a document starting from 0 not 1? It means when i upload a document the first version become 0.0 I have the openkm development environment and there is no problem to change source code if it need a...
by mamad
Thu Feb 14, 2019 9:51 am
Forum: Configuration
Topic: Where database files stored ?
Replies: 2
Views: 167

Where database files stored ?

Hi guys, Im using openkm 6.3.6 community edition which hosted on a Debian Linux server I want to know where database (i mean whole database) store in file system ? I made a back up from tomcat-8.5.24 folder of server and changed database for some tests After a couple of changes in database i decided...
by mamad
Wed Feb 13, 2019 2:08 pm
Forum: Configuration
Topic: How install my extended version of openkm on a real server
Replies: 12
Views: 1909

Re: How install my extended version of openkm on a real server

I guess this problems relate to droping OKM_AUTO_METADATA table. in the documentation (https://docs.openkm.com/kcenter/view/okm-6.3-com/migrating-from-636-to-637.html) you say we have to run this script : DROP TABLE OKM_AUTO_METADATA; ALTER TABLE OKM_AUTO_ACTION DROP COLUMN AAC_TYPE; ALTER TABLE OKM...
by mamad
Wed Feb 13, 2019 2:05 pm
Forum: Configuration
Topic: How install my extended version of openkm on a real server
Replies: 12
Views: 1909

Re: How install my extended version of openkm on a real server

i migrate successfully from 6.3.6 to 6.3.7 and openkm runs good (doing all steps) (i install 6.3.6 online and migrate from it to my developed version ) but now i cant access Workflow and Automation part of openkm (i defined some automation actions before migration to 6.3.7 ) when i go to workflow pa...
by mamad
Wed Feb 13, 2019 8:14 am
Forum: Configuration
Topic: Cant Deploy process definition to server
Replies: 1
Views: 86

Cant Deploy process definition to server

Hi guys, I'm trying to add some work flows to openkm with JBPM Based on instructions at openkm documentations,i made a new process definition with eclipse tools (Im using the eclipse inside the development environment of openkm (virtual linux mint os) ). The problem is that i cant deploy the process...